Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

CMS50F v3.9 Pulse Oximeter
#1
Not sure what I have done wrong but now here is my problem.

The Oximetry data is not coming in correctly and when I delete the oximetry data in sleepyhead everything looks great, but if I exit and get back in some information that is the screwed up data comes back.    When I am in Sleepyhead and I delete the data and get sleepyhead data back to where everything is correct again rather than exit how do I save everything so when I exit and get back into it  .... it will look the same as it did when I close out or exit the sleepyhead program.......    I have tried to just delete the oximetry data, I tried to delete both the CPAP and Oximetry data for the two days now that I am showing a problem with and after I delete this information and Sleepyhead looks great   all I do is exit and get back into Sleepyhead again and those days have the extra sessions of something that say I have recorded 47 hours for one day and 63 hours the other.  

Not sure how to properly delete information  save the program and get back into the program without these garbage sessions coming back  some how when I am deleting it just removes the information current I am viewing within sleepyhead and not deleting the actual files that it pulls in on my computer the next time I get into sleepyhead again.

Let me know if anyone can see what else I can try?
Post Reply Post Reply
#2
You may need to find where Sleepyhead has stored those imported files on your computer and remove those.
                                                                                                                                                                                  
Please organize your SleeyHead screenshots like this.
I'm an epidemiologist, not a medical provider. 
Post Reply Post Reply
#3
I not sure what I ended up doing but I finally got all the Oximetry data purged and now I can get out and back into Sleepyhead without messing up the CPAP graphs.

Thank You
Post Reply Post Reply


#4
Dear Forum,  

I had recently purchased the CMS50F oximeter to add the Pulse Oximetry date into the CPAP Data and was having some issues once I added that data to the 40 previous days of CPAP day that I had already on the Sleepyhead Software as it seemed to make a mess out of my CPAP data that looked find .    I finally was able to fix my problem and cleared out all of the Oximetry data so it no longer effects the CPAP data.

I question to the forum is does anyone else have the CMS50F with Version 3.9 software on it.   The reason I ask is this Oximeter now claims it can record up to 72 hours of data not just 24 hours .   If this is true it may be the reason I was having issues when down loading my Oximeter data in to my CPAP data for Sleepyhead to read.     As it seemed for some reason that Sleepyhead took this file expecting the max length to be <24 hours and now it can record and download up to 72 hours as I was getting total sessions of 50 hours or more all packed into one day, so that may be why Sleepyhead did not know how to handle it????

Let me know if any one else has CMS50F v3.9 now and have had no problems to download this data into Sleepyhead.

C2workout.
Post Reply Post Reply
#5
are you turning the record off when you wake up, you are trying to upload 8 hours worth of data?

it could also be easier to follow, if you keep it all in the same thread
Post Reply Post Reply
#6
Yes, I did stop the recording as soon as was done sleeping which was between 8-9 hours on my CMS50F  Not sure I understood your second question?   I was just trying to upload what I recorded for that night's session which was about 8-9 hours but I did not clear out anything that might have been in the CMS50F.    As I thought that everytime you start recording it overwrites or clears memory and then records until you set the unit to stop recording which I did that for the two times I used it to try to have Sleepyhead read both the CPAP and Oximetry data.   I did see my data there but it seem to continue to indicate some junk or emptiness for another 40 to 60 hours besides my actual data.   So where your graphs get very compressed when you have a total session show up that is almost 3 days long. 

I can read the data with the Software that came with the Oximeter but it will not be displayed along with the CPAP data.    I made sure to start the recording at the same time as I started the CPAP.  Set all the time so they were Sync'ed together.  It just did not work with the latest verison of Sleepyhead.   So to the best of what I know I thought I did everything correctly .    Open to suggestions but before I try it again I would like someone to let me know that has this exact v3.9  and the SpO2 software v3.0.2 for the software that comes with the CMS50F v3.9
Post Reply Post Reply


#7
I also have a CMS50F v3.9 and I'm using the SpO2 v3.0.2 software that comes with the CMS50F v3.9.  I am using SleepyHead v 1.0.0 beta-2.  I also have the same problem you described, pulse and O2 data being longer than actually recorded.  For me that problem happens when I try to import directly from the CMS50F into SleepyHead.  If I instead load the data into SpO2 Assistant 3.0.2 and then load the resulting .Sp02 file into SH it imports at the correct length.  

I discovered that when I have a SH database that has ever had the CMS50F data loaded directly to it, even after deleting that data from the database and importing the .SpO2 file, and thinking everything looks good, the problem you described on exiting SH and having the recorded sessions lengths be too long for pulse and O2 sometimes comes back.

I got so frustrated with this that I rebuilt my SH database from a time before I started importing oximetery data, re-imported my current CPAP data, and have made sure to never load directly from the CMS50F but only from .SpO2 files, I have not had the problem come back (yet).
Post Reply Post Reply
#8
Thank you,   I thought my mind was lost for ever and when know one on the forum had this same problem I thought it was just me.  So if you would go through this slowly with me.  Currently some how I did not have to rebuild my SH data over again and it is working great and is not recreating the problem with my CPAP data so if you could walk me through the step of how I would import the files from Sp02 v3.0.2 back into SH so it works correctly for displaying both.    For give me as I am a bit older and the brain is not what it once was and I get very upset with myself if I screw my SH up again.    Let me know and I will let you know if I was successful or not.  Thank You  C2workout.
Post Reply Post Reply
#9
I may not explain this well enough, and even if you do it the way I do, your problem could rear it's ugly head again so make sure you backup all your SleepyHead data files so you can restore them if this goes badly.

What you want to do is find the .SpO2 files that SpO2 Assistant creates and have SH import them.  With my version of Windows I can't import the files directly from where SpO2 assistant stores them.  I need to copy the .SpO2 files somewhere else, like the MyDocuments subdirectory and then have SH import them from there.

Finding the .SpO2 files can be tricky.  On my computer they're in a subdirectory off the hidden subdirectory called AppData.  Mine is at C:\Users\Dave\AppData\Local\VirtualStore\Program Files (x86)\SpO2 Assistant V3.0.2\Data

Once you find the .SpO2 files copy them to somewhere usable, run SH, select Oximetery Wizard, Import from a datafile, and select the .SpO2 file you want to import.

I hope this works for you.
Post Reply Post Reply


#10
Just a Heads up to the forum,  If you have current model of the CMS50F v 3.9 Pulse Oximeter it does not like to upload into the current version of Sleepyhead.  I and another person on the forum had also confirmed that it may make a mess with your CPAP data for the days you have uploaded your Oximeter data for.   Not sure how to let Sleepyhead know the information to look at to see what it might take to correct the upload problem so at this point if you are using CMS50F v3.9 beware you may which you did not try it until maybe the next version of Sleepyhead comes out, or double check the release note for the next version to see if it is able to then work with that version of the CMS50F....   Re read from the beginning of this post and threads to better understand the problem.   It is not easy to correct this problem/ undo the download as you can not just delete the Oximeter data and or delete both or all the data for the dates of the oximeter data you loaded  and then reload the CPAP data from the SD card again.    So BE CAREFUL
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to reset oximeter events (pulse, spo2) fizassist 2 97 08-09-2017, 10:11 PM
Last Post: fizassist
  Which Contec Pulse Ox works 100% w/Sleepyhead? worg 3 206 08-09-2017, 05:48 PM
Last Post: aquanaut20
  CMS50K Oximeter snyd71 13 3,848 07-22-2017, 07:06 PM
Last Post: ysundfw
Question SleepyHead & CMS50F Oximeter & Mac Big Dog NY 16 5,183 06-19-2017, 01:55 PM
Last Post: personal111
  Importing CMS50D+ oximeter data to my WIN 7 BrassCat 10 458 06-13-2017, 03:13 PM
Last Post: adrinef
  CMS50F Pulse Oximeter c2workout 3 332 05-04-2017, 08:04 PM
Last Post: c2workout
Question SleepyHead only partially parses oximeter data Wrz77 1 290 03-30-2017, 11:55 PM
Last Post: Wrz77

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.