Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

[CPAP] Trouble shooting resmed 100
#1
Question 
Hi. Just went to use my resmed lumis 100 tonight. With my oxygen concentrator on. Oxygen fine as I used it at tea time abd can feel the oxygen coming through when i take the cable out. It felt like no oxygen coming up through the mask and almost felt like I couldn't breathe properly. And my face was warming up. Felt clostraphobic. Felt like there was no force on my breathing. It started up okay. Something didn't feel right. Any ideas? Hope this make sense.
Post Reply Post Reply



Donate to Apnea Board  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Trouble with getting my machine through airport screening dozydave 8 323 07-07-2018, 02:56 AM
Last Post: holden4th
  [CPAP] Trouble with leaks and pressure Kristin 41 2,513 06-24-2018, 08:47 AM
Last Post: Kristin
  Started CPAP earlier this year, but I'm having a little trouble Zraigy 6 282 05-27-2018, 07:43 PM
Last Post: Ockrocket
  ASV AHI trouble fiur 8 514 05-09-2018, 10:07 PM
Last Post: Sleeprider
  Trouble falling asleep lasalle 3 233 04-28-2018, 05:06 PM
Last Post: ghce
  Trouble keeping my mouth closed Kryogen 26 1,351 10-09-2017, 08:58 AM
Last Post: SarcasticDave94
Question [Equipment] trouble moving from RemStar Auto to AirSense 10 jim.evo 53 2,351 08-31-2017, 04:39 PM
Last Post: jim.evo

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.