Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

[Equipment] Unit not working
#1
Gross 
hi All,

My Philips Respironics RemStar Auto A Flex System 1 has stopped working. It was making a hot, 'electrical' smell and now it acts as if there is no power ie the backlights don't work and nothing turns on.

Are there any internal fuses that may have blown that I could replace or this a technician repair job ? looking through the service manuals it seems it may need the main power board replaced to fix it. Is this something I can do ? Any help would be greatly appreciated.

Cheers
Post Reply Post Reply
#2
What generation is this machine? If it can't be fixed with a new power cord, it won't be worth fixing at all. Do try a new power adapter before giving up. If that doesn't work a new machine is probably going to be needed. Your location (AUS) is going to make this more expensive than replacement in the U.S., but some of our vendors do ship (See Supplier #2).
Post Reply Post Reply
#3
Hi Monty6894,
WELCOME! to the forum.!
I agree, try a different power supply first before you give up on that machine..Good luck to you with getting it working.
Hang in there for more responses to your post.
trish6hundred
Post Reply Post Reply


#4
Hi Monty6894 and welcome to the forum!

Sounds like you have either an electrical cord problem or a defective machine. Hope you can get this sorted out quickly! It would help if you could take a moment and fill out your user profile settings with regards to the Model # of your Respironics System 1, the mask type and name, pressure setting(s)-whether straight cpap or auto cpap, etc.

By the way, are you new to cpap, and if not, how long have you been being treated?

Good luck getting back up and running soon!
APNEABOARD - A great place to be if you're a hosehead!! Rolleyes

-------------------------------------------------------------------------------------------------
EVERY ACCOMPLISHMENT BEGINS WITH THE DECISION TO TRY!
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [CPAP] CPAP working but Still Exhausted BigT 8 303 11-11-2017, 06:30 PM
Last Post: BigT
  Is it Working? shinkdavid 20 1,051 11-04-2017, 12:43 PM
Last Post: SarcasticDave94
  Is my humidifier working or not? Roger Oscar Lima 9 419 11-02-2017, 06:33 PM
Last Post: Roger Oscar Lima
  Res Med S9 just stopped working!` sjssf 11 327 10-31-2017, 10:23 AM
Last Post: Spy Car
  algorithm not working for me elocin71 3 195 10-16-2017, 05:24 PM
Last Post: trish6hundred
  It's not working. Panicking and need help. taha 23 792 10-15-2017, 10:57 AM
Last Post: Sleepster
  Repairing an imported unit (US to Australia) zymurgy42 13 362 10-08-2017, 01:42 AM
Last Post: Ockrocket

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.