Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

[Equipment] humidifier on Remstar Pro
#1
I bought a new reservoir put it in my humidifier and now nothing works. I have humidifier set on 5. Machine starts and little heater light is blinking all the time. the cpap runs and then shuts off every few minutes and then auto start tuns it back on. If I shut the humidifier off, then the cpap does run OK. Do I have a setting wrong, or is the humidifier broke. The tin on bottom of reservoir came off is reason I had to order new reservoir.
Reply
#2
Aubra, I don't have that machine and can't answer BUT, I updated your subject line so that those who know the answer can respond quickly.
PaulaO2
Apnea Board Moderator
www.ApneaBoard.com


Breathe deeply and count to zen.

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.




Reply
#3
Hi Aubra,
WELCOME! to the forum.!
I don't know the answer to your question but hang in there, someone will be able to help you.
Best of luck.
trish6hundred
Reply


#4
I dont have that particular model of the Remstar but looking at the trouble shooting in my manual and what your light is doing plus what you describe try this.

Shut everything off. Separate the humidifier and blower units from each other. The reattach them making sure they are attached firmly and correctly. If that doesnt work im at a loss.
Reply
#5
If that does not work I would guess that there might be a problem with the power supply or the humidifier. If it is a separate power supply brick and is the same one you were using before, try getting it out in the open and direct the output of a fan on it. see if it works then. I am not into testing electronics but my guess then would be that the power brick is failing and not able to supply enough power so overheats and shuts down.

That's my 2 cents for whatever it is worth.

Best Regrds,

PaytonA
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Remstar Auto M Series "Service Required" msgill59 3 48 8 hours ago
Last Post: trish6hundred
  Data Card Read for REMStar Pro C-Flex Auto IQ HenryECole81 8 103 01-19-2017, 09:02 PM
Last Post: trish6hundred
  Septoplasty with APAP and humidifier? alisa 7 181 01-18-2017, 11:08 PM
Last Post: trish6hundred
  Water Changing in H5i Heated Humidifier ppca 4 143 01-18-2017, 01:47 AM
Last Post: ppca
  Dreamstation Humidifier Question Newbee2016 11 330 01-15-2017, 07:02 PM
Last Post: Newbee2016
  [Equipment] Humidifier filler Bob Engelhardt 18 534 01-14-2017, 12:48 AM
Last Post: chill
  No setup menu option RemStar Pro 460P buschjd 9 187 01-11-2017, 05:58 PM
Last Post: OpalRose

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.