Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

FlashAir tests [failure and success]
#1
FlashAir tests [failure and success]
I was curious as to why some users have failures with their FlashAir cards and if there may be a common cause.  So I took my working FlashAir card and did some experimenting.  Your results may vary....
I don't recommend anyone try this as there is always the potential to ruin the card!  And these are not instructions how to setup the card to work with your xPAP machine!!!  But the results here may or may not help someone along the way.

The TL;DR version:  I ruined my FlashAir Card using an external card reader.  I got it working again using my laptops internal card reader.

First my basic setup for testing:
  • FlashAir W-04 64GB card (purchased June 2020). I had it formatted as 32GB, FAT32
  • My Mac (see my sig for details)
  • Internal card reader on my Mac
  • An external card reader (Ugreen, 4 slot reader with USB 3.0 cord)
  • SD card formatter (free) from SD Association (https://www.sdcard.org/downloads/formatter/)
  • Mac's built in Disk Utility
  • Mac's terminal (for running diskutil and dd from CLI)
  • BBedit (free version) for modifying the config file
  • Toshiba FlashAirTool.app
Obviously I had a backup image of a working copy of my card and a copy of all my xPAP data!

I've listed things in different subsections below....

First thing was to restore the card to its original 64GB ExFAT glory.  I used the SD card formatter mentioned above which gave me a blank slate to start.

External card reader (Ugreen):

  1. Using the FlashAirTool.app I initialized the card.  Following the series of the eject/insert prompts, it finished without issues.
  2. Next step was to change the network settings using the FATool.  I left the default "flashair" and added the password "12345678" and applied the changes.  Followed the prompts for remove/insert card.  Seems to have gone well, but no signs of WiFi yet.
  3. Double check that "Wireless Lan Startup Mode" was set to Automatic and left the default 5 minute timeout.  Still no signs of wifi
  4. Used the FATool for "FlashAir Drive" setting to enable that feature.  Followed the remove/insert prompts. The tool would try to write to the card but eventually failed.
I noticed my Mac was leaving its usual hidden files (dot files) on the card during each process.  After the first try, I started deleting those files at every step along the way just in case.
I reformatted the card and started from scratch again.  Each time trying a different variation of removing the card from the external reader when instructed, disconnecting the external reader from the computer, and a combination of both.  I reformatted 4 times (Disk Utility) and each time I tried to get the card to a working state it failed!  Never got the WiFi or networking to run.
I was still able to read/write/copy to the FlashAir card using Finder, just could not get the WiFi/Networking running, period.  It was just an expensive SD card at this point.

On to the next part of my experiment.....

Internal SD card reader (Mac):

  1. Reformat the card (Disk Utility) 
  2. Use FlashAirTool.app to initialize the card.  Follow prompts, all went well so far
  3. Changed network setting using FATool.  Left the default "flashair" and added "12345678" as password and applied changes. Followed prompts.  The tool finished what it was doing.  No "flashair" in my Wifi at this point.
  4. Using FATool for FlashAir Drive" setting to enable the feature.  Followed the prompts.  It failed again.
  5. Having realized I forgot to delete the hidden dot files this time around, I started at step 1 again.  This time deleting the hidden dot files at each step along the way.
  6. Then the magic happened.  I had "flashair" in my WiFi and was able to connect to it.
Just to make sure it wasn't some fluke that it started working again, I reformatted the card using the internal card reader 3 more times (using a combo of Disk Utility app, and diskutil from CLI) and followed the procedure each time (including deleting the dot files).  And each time it worked!
Using BBedit I modified the config file to make it the same as it would be in my xPAP machine, and that I would be able to mount it properly to copy the data.  All worked well!

Now that I was done tinkering I had a working 64GB ExFAT FlashAir card with a static IP that I could mount on my network.  I needed to turn it back into a 32GB FAT32 for my xPAP machine.  So one more format, insert into xPAP, initialize, etc, etc,. Copy all my xPAP data back to the card using rsync.  Put it back into my xPAP and it recorded last nights data without missing a beat.

If your keeping count, that's 10 times the card was formatted (11 if you include the last time I restored it to a 32GB card and copied data back to it)



Conclusion:

The FlashAirTool.app seems to have an issue with my external SD card reader.  Not sure if it's my particular make/model or if it's all external readers, or the combo of Mac and the external reader, maybe a driver issue.  But using my laptops internal reader did the trick for me.

FlashAirTool.app also seems to have an issue with the hidden dot files Mac insists on putting onto everything it comes into contact with.  (Windows writes the hidden files also, but I can't confirm if it might be an issue).  So try deleting those as they popup.

So if you have a seemingly bricked FlashAir card, you might be able to resurrect it by using an internal (or different) card reader and/or deleting the hidden dot files your OS creates on the card.  No guarantees though....

The FlashAirTool.app contains all the necessary files that get placed onto the SD card.  Although I'm not sure how FATool can tell that it is a FlashAir card after it has been formatted.  Some type of identifier/serial number burned into the card somewhere? Didn't dig that deep into it....

On a side note:  I had a moment of lucidity during all of this and made an image of the 64GB card with basic WiFi working Smile
Using a 13" MacBook Air (2017), MacOS Catalina (10.15.7), OSCAR v1.2.0
In a VM: Win10 1909 (18363.1139)

Installing OSCAR on a Mac
Organizing your OSCAR charts
Attaching images and files for the forum
OSCAR Help
OSCAR Data Interpretation
Post Reply Post Reply






Donate to Apnea Board  
#2
RE: FlashAir tests [failure and success]
As far as to how the FlashAir Tool knows it a FlashAir card; The FlashAir cards use an Airoha Wi-Fi chip.  Others, like the Voorca, use the USI (Avnet) 850101 chipset and Voorca use an Atheros chip.


The 850101 is a combination wireless module (Broadcom BCM43362) and micro controller (ST Microelectronics STM32F205).
Crimson Nape
Apnea Board Moderator
www.ApneaBoard.com
___________________________________
Useful Links -or- When All Else Fails:
OSCAR Chart Organization
Attaching Images and Files on Apnea Board
Beginner's Guide to Sleepyhead and OSCAR
Apnea Helpful Tips

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [split] 64Gb FlashAir WiFi Setup Problems (todivefor) todivefor 98 1,803 10-19-2020, 12:54 PM
Last Post: Crimson Nape
  64Gb FlashAir WiFi Setup Problems [Guy] GuyScharf 16 611 09-10-2020, 04:01 PM
Last Post: Crimson Nape
Cool Recommendation: FlashAir and Flashpap - Wifi data transfer from CPAP to PC/Sleepyhead mogulman 38 6,342 09-07-2020, 06:09 PM
Last Post: Bobaloo
  OSCAR on Asus Chromebook success tonyt 2 153 08-18-2020, 01:11 AM
Last Post: tonyt
  FlashAir Mapped to Drive OSCAR Can't See Network ResidentSleeper 5 255 07-07-2020, 08:11 AM
Last Post: Crimson Nape
  FlashPAP - FlashAir WiFi SD card utility TiredToo 292 70,321 06-12-2020, 11:47 AM
Last Post: Crimson Nape
  Failure mode - what does it mean lwojcik 6 335 03-20-2020, 04:17 PM
Last Post: sawinglogz


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.