Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account

New Posts   Today's Posts

Getting Message to Format My SD Disc
I'm still stuck!  Took my laptop in to my tech for some other tweaks and he did his best to update all drivers.  We did format the new SD card in my laptop--card was doing it's job recording CPAP information--as I knew the machine would put the info back on.  That night when I put it in my CPAP got bells and whistles telling me the SD card was corrupted and to format it  I did so (in the machine) and has worked well on the machine statistics since.  It still won't work on the laptop  I have used both my built-in card reader and a usb portable card reader--same results.  Took two SD cards (one Respironics one and a new PNY card) to my DME office and both cards work fine on their computer.  If it helps any computer techies out there, I'm using a high end Dell Vostro 3750 laptop made in 2013, refurbished by a licensed Microsoft repair guy with Windows 10, a new motherboard and upgraded hard drive.  It is big, heavy and fast and I love it--except for this problem.  I NEED to be able to red SH on a portable device!
Post Reply Post Reply

Donate to Apnea Board  
It looks like you have some serious problem with your usb-thingies. (all that SD-stuff including the build-in reader are using the usb-root-hub)

what you can try: first make a clean boot! (the normal reboot, shutdown or power off does not make a complete shutdown!)
keep the shift-key pressed while you click on "shutdown / power off" in the start-menu.

disconnect every not absolutely necessary usb-device (this includes the mouse - you have a touchpad build in)

restart / power on your windows.
write protect your sd-card.
try to access the sd-card with the explorer and copy the content of that over to your hard-disk.

Before you disconnect any usb-device unmount it using the usb-icon in the systemtray (that really helps a lot) - this includes all SD-Cards!

If that works (more than just once) you need to do some tweaking ... starting point would be to disable all the fancy energy-saving crap (only) for the USB-devices. (basically your root-hubs and the controller)
Disabling fast startup in windows 10 in general solved like a ton of driver related problems for me. (I barely restart .. I always hibernate (which does not work out of the box^^))

if that doesn't work or is simply not for you, you can try something different:
if your router / accesspoint has USB and some basic nas functions you can also try to plug your (write protected) SD-Card with your external reader in there. Or if you have some sort of "home-Nas" or a printer - most of them have SD-Readers build in^^
.. or simply use a wifi-sd-card^^ (although that might be a little bit out of your comfort zone)
Post Reply Post Reply
Thanks so much, TBMx. The info on the USB hub might be the problem. My two USB 3.0 plugs connectors quit working this weekend--our computer guy has replacements ordered for install tomorrow. The USB 2.0 still works. I'm going to copy this email and take it to him--I'm not technically-inclined enough to try this on my own! I had thought of using a wifi SD card--I know I can get help for step by step install from the good folks here on the forum. Don't know much about them--I imagine it also goes through the router? I hope to have something working that we can use off the grid in our travel trailer--I have a battery pack for the CPAP machine and we have a generator to provide power to recharge batteries.
Post Reply Post Reply
well .... in that case thinking about the wifi-SD-Cards might really be an option! and if it's only a mere backup-solution in the end.

BUT, there is one thing that you should check before even considering that: your xPAP-machine has to tolerate other files and folders on the sd-card. ... from what I understood so far that might NOT be the case with your device. The newer ones seem to tolerate that - the older ones tend to be very picky about what can and cannot be on the sd-card.

I would - as I do always for that many reasons - advice to not connect that wifi-card to the router but instead create your own access-point. Has the unbeatable advantage that the wifi-function gets *automagically* turned off if no device connects to it during a given timeframe therefore limiting access drastic and you avoid any radiofrequencies which may or may not interfere with your machine at night or might affect you. ... and it works "on the road" if your router is no longer with you.
Downside is - of course - that you have to turn the power from your xPAP-Device off and on again in order to restart the wifi-function.

And you still can use that as a "normal" SD-Card.

(the setup-process from the sd-card looks way more complicated, than it actually is^^ - but you should be really sure that your device works with a wifi-sd-card!)
Post Reply Post Reply
Thanks you for trying to explain things to this electronically-challenged old gal!  Today our tech found that the USB 3.0 slots got shut off somehow.  He was prepared to replace them but turning them on worked.  He also gave me a new USB card reader and it works with two of my three SD cards so I am back in business with my laptop.  The built-in SD card reader still doesn't work.  I was going to go to his shop Friday with my CPAP machine and laptop and get into the wi-fi business, but decided not to as long as things are working OK now.  The new SD card reader seems to work in my PC also--which was also having problems.   I appreciate all the help from everyone--hope I won't be back here soon!
Post Reply Post Reply

Donate to Apnea Board  
The PRS1 DS560 should have no problems with the flash card files. The only machine that seems to be bothered is the Resmed S9.
Post Reply Post Reply
The cards work fine in the PR 560--it has been getting the info into Sleepyhead that was the problem. The new USB card reader seems to have solved the problem--the built-in SD card reader still says card needs to be formatted.
Post Reply Post Reply

Possibly Related Threads...
Thread Author Replies Views Last Post
  SD card forced a format after i copied to pc. Can I merge data? Thelgow 4 297 05-02-2018, 01:16 PM
Last Post: jaswilliams
  ResScan Access Denied message jbee18 20 1,099 03-09-2018, 12:51 PM
Last Post: ShaunBlake
  Error message installing ResScan PaulaO2 5 467 02-24-2018, 09:06 PM
Last Post: AlanE
  Format SD Card for ResMed S9 Sleepster 2 583 01-18-2018, 10:02 PM
Last Post: Sleepster
Question Slow reading of SD Disc-EncoreViewer2 Robbo511927 7 709 09-28-2016, 07:23 PM
Last Post: Robbo511927
  Location/Format of SleepyHead Data TillerBee 8 1,913 09-26-2016, 10:11 PM
Last Post: beet
  Best way to format & organize SD card for multiple brand CPAP machines? verbatim1 4 696 06-10-2016, 06:30 AM
Last Post: Crimson Nape

Forum Jump:

New Posts   Today's Posts

About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.