Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Help Cpap stopped working in Mexico
#1
I have a remstar pro m series and it starts beeping and flashing saying service is required. Anything I can do?
Post Reply Post Reply
#2
Try unplugging it for about a minute then plug it back in to reboot it. If that doesn't work try disconnecting the humidifier. Hope this helps
Post Reply Post Reply
#3
Hi Joan.pete,
WELCOME! to the forum.!
What givememoresleep said.
Hang in there for more responses to your post and best of luck to you on getting your machine working.
trish6hundred
Post Reply Post Reply


#4
Is there a specific error code that shows up on the screen?

If so, here's a thread that lists what the codes mean and how to fix the issue:

http://www.apneaboard.com/forums/Thread-...AP-machine

SuperSleeper
Apnea Board Administrator
www.ApneaBoard.com


INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.



Post Reply Post Reply
#5
(02-21-2013, 09:58 AM)Joan.pete Wrote: I have a remstar pro m series and it starts beeping and flashing saying service is required. Anything I can do?

You're not using any of that Mexican water, are you?
That will mess it up big time. Vomit
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  AirSense 10 Humidifier is not working spooky101 10 4,728 04-20-2017, 09:40 PM
Last Post: Raysie
  AirCurve 10 stopped working Papit 6 155 04-13-2017, 02:26 PM
Last Post: justMongo
  Help! Changed CPAP Settings, Now Machine Not Working cj789 9 376 04-09-2017, 05:18 PM
Last Post: Ockrocket
  High AHI's in Mexico City Sterling147 21 619 04-07-2017, 07:11 PM
Last Post: Sleeprider
  Airsense 10 For Her Wireless Not Working silvem 8 203 04-07-2017, 04:48 PM
Last Post: jtravel
  [CPAP] Is it normal to hear a subtle whistle when the machine is working? juanjo 19 888 03-22-2017, 11:52 PM
Last Post: SithLord
Sad [CPAP] CPAP stopped working Kjlittle61 3 259 03-10-2017, 07:15 PM
Last Post: trish6hundred

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.