Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Help Cpap stopped working in Mexico
#1
I have a remstar pro m series and it starts beeping and flashing saying service is required. Anything I can do?
Post Reply Post Reply
#2
Try unplugging it for about a minute then plug it back in to reboot it. If that doesn't work try disconnecting the humidifier. Hope this helps
Post Reply Post Reply
#3
Hi Joan.pete,
WELCOME! to the forum.!
What givememoresleep said.
Hang in there for more responses to your post and best of luck to you on getting your machine working.
trish6hundred
Post Reply Post Reply


#4
Is there a specific error code that shows up on the screen?

If so, here's a thread that lists what the codes mean and how to fix the issue:

http://www.apneaboard.com/forums/Thread-...AP-machine

SuperSleeper
Apnea Board Administrator
www.ApneaBoard.com


INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.



Post Reply Post Reply
#5
(02-21-2013, 09:58 AM)Joan.pete Wrote: I have a remstar pro m series and it starts beeping and flashing saying service is required. Anything I can do?

You're not using any of that Mexican water, are you?
That will mess it up big time. Vomit
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [CPAP] Is it normal to hear a subtle whistle when the machine is working? juanjo 10 287 02-21-2017, 09:36 PM
Last Post: juanjo
  So comfy, I thought it wasn't working Hydrangea 18 614 01-20-2017, 02:37 AM
Last Post: ppca
Brick [Equipment] ResMed 10 just quit working mid nap!! Anyone had this happen? Please any help,apprec! Ulong 8 448 01-03-2017, 11:01 AM
Last Post: Sleeprider
  3B Luna Auto-PAP Humidifier Not Working dinesh21 4 174 01-02-2017, 10:08 PM
Last Post: Sleeprider
  humidifier stopped working kapebretoner 7 16,328 12-19-2016, 10:31 PM
Last Post: Beej
  [Equipment] ResMed Airsense 10 Quit Working SherrieR 4 504 11-26-2016, 07:51 PM
Last Post: trish6hundred
  [CPAP] Changes in how the machine has been working? Xinectyl 9 451 11-07-2016, 12:02 PM
Last Post: Xinectyl

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.