Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Humidifier Problem PRS1
#1
Help! I have a Philips-Respironics PR System One Series Machine. Each night I dutifully fill the water chamber for the humidifier, and each morning, the chamber is still full--the humidifier is not working! I have checked both the regular and clinician settings, and everything *seems* to be turned on correctly (humidifier set to 5, etc.). I just got it back from the repair center, and after paying $90, it STILL doesn't work? Can anyone tell me what might be wrong?
Post Reply Post Reply
#2
(01-19-2014, 10:08 PM)DianaK Wrote: Help! I have a Philips-Respironics PR System One Series Machine. Each night I dutifully fill the water chamber for the humidifier, and each morning, the chamber is still full--the humidifier is not working! I have checked both the regular and clinician settings, and everything *seems* to be turned on correctly (humidifier set to 5, etc.). I just got it back from the repair center, and after paying $90, it STILL doesn't work? Can anyone tell me what might be wrong?
Hi Diana, sorry I can't help, I just feel for you. What did the repair guy say? Did he fix anything? Have you phoned him since you have brought it home and told him it is still not working? Maybe he could guide you through the process of it all.
Sorry, really wish I could be of some help for you. Hopefully someone with same machine will see your call for help. Good luck.
PS maybe ring Philips, that's what I would be doing.
Sleep Tight...
Gabby
Post Reply Post Reply
#3
DianaK, I updated your subject line so that the people with the ability to help you can get here quicker.
PaulaO2
Apnea Board Moderator
www.ApneaBoard.com


Breathe deeply and count to zen.

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.




Post Reply Post Reply


#4
DianaK there should be some troubleshooting info in the book that came with your humidifier. Check there and see if you can find a problem that matches what your humidifier is or isn't doing.
Post Reply Post Reply
#5
(01-19-2014, 10:08 PM)DianaK Wrote: I have checked both the regular and clinician settings, and everything *seems* to be turned on correctly (humidifier set to 5, etc.).
Try classic mode, uses more water but might have to keep an eye for any rainout. If rainut occur , lower the setting a notch and get a hose cover

From the manual:
• Humidifier - This setting allows you to choose the desired humidity setting: 0, 1, 2, 3, 4 or 5. If the System One humidity control has been disabled, the classic style of basic temperature controlled heated humidification will be used and the display will show: 0, C1, C2, C3, C4 or C5 for these settings. This will only display if the humidifier is attached



Post Reply Post Reply
#6
In what way is it not working?

When you press the start button:
Does the humidifier light (the little steam Icon on the left of the knob) come on?
Does the Humidity number beside the knob come on?

Mine has an issue where the humidifier doesn't work after I have transported the machine. I slap it around a bit and it is OK again until my next trip.
Post Reply Post Reply


#7
Try what Zonk said.

I have the same humidifier and turning off the system one humidification and using manual settings should definitely work.

If it still doesn't work call back your repairman because there is something physically wrong with the unit.
Post Reply Post Reply
#8
If it's one of the newer System One machines (560, 660) pressing down and holding the control knob for 5 seconds or more should turn on the humidifier pre-heat (for 30 minutes). The humidifier indicator light should come on to confirm it, without the fan running. Wait a few minutes, remove the humidifier reservoir, and see if it's warmed up.

Please let us know the specific model number, and someone more familiar with your model may be able to advise you better.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  drying humidifier amd tubes SleepyBee 4 82 11 hours ago
Last Post: Raven87
  [CPAP] Returning to CPAP, Is my pressure too low (flow limitation problem)? See chart please MarkSleeps 6 216 Yesterday, 08:00 AM
Last Post: MarkSleeps
  Resmed S10 water leak from humidifier darren79 37 13,252 06-25-2017, 10:18 PM
Last Post: CB91710
  Problem with Sleepyhead interface Crustycabs 3 99 06-16-2017, 08:53 AM
Last Post: TASmart
  [Equipment] Vendor that sells just the seal for ResMed AirSense Humidifier? Alameth 9 395 06-03-2017, 02:24 PM
Last Post: CB91710
  New old problem. I can use some input. smiledog 10 378 06-03-2017, 12:55 PM
Last Post: smiledog
  Help me understand how humidifier levels are managed by the xPAP DanPrado 16 430 05-21-2017, 08:56 PM
Last Post: Sleepster

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.