Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Linux kernel upgrade ideas requested
#1
I have an o-o-o-old version of Linux (2.4.21 Kernel - circa 2001) running on a 128Mb DOM in my security DVR. I want to upgrade the system's hardware but the OS is so old that the kernel has a panic attack when it boots. The message "Chipset not recognized" is displayed.

I have a copy of the DOM's contents so they can be viewed. . .in case anyone needs to look at it.

Zoneminder is an option but I was hoping to try and stick with this system because of its extremely fast boot time (20-30 seconds).

Anyone wish to give me some ideas on how to perform a kernel/OS upgrade on this system? I don't care about the new size. I'll make adjustments for that.

Statistics prove that people who have more birthdays live longer.
Post Reply Post Reply
#2
Have you looked at some of the really small installations such as Puppy Linux, SliTaz, or Damn Small Linux?
Apnea Board Member RobySue has posted a Beginners Guide to Sleepyhead Software here:  http://www.apneaboard.com/wiki/index.php...SleepyHead

Download Sleepyhead
Organize your Sleepyhead Charts
Post from Imgur


Post Reply Post Reply
#3
Is there a reason for not upgrading to a Raspberry PI? I am not familiar with your application.
I am not a Medical professional and I don't play one on the internet.
Started CPAP Therapy April 5, 2016
I'd Rather Be Sleeping
Post Reply Post Reply


#4
The Raspberry just doesn't have what I need. I'm needing to use an old 865PE chipset motherboard. The 865PE was the last mobo(2005) that had 6 PCI slots plus an AGP. I'm using it for a 16 camera security DVR system. Each card supports 4 cameras. I use one of the PCI slots to upgrade to 1000Mb network card, the onboard NIC is a 100Mb. Unfortunately, the Linux version that currently runs the system is older than this board and doesn't recognize its chipset. I'm trying to make do with what I have so I only expend time and not bucks. I starting to think that this is a pipedream.
Statistics prove that people who have more birthdays live longer.
Post Reply Post Reply
#5
So you are trying to upgrade from a 100mb ethernet to a 1000mb ethernet?
I am not a Medical professional and I don't play one on the internet.
Started CPAP Therapy April 5, 2016
I'd Rather Be Sleeping
Post Reply Post Reply
#6
Not exactly. The upgrade to the 1 Gig NIC was just a plus because I had both an extra card and an available PCI slot. . . I should have left that out of my last post since it doesn't pertain to my goal.

The mobo I currently have in the system is an 845(2002) chipset and I want to upgrade to the 865. The Linux version that is running on the 845 won't recognize the 865. The Linux OS being used is very minimal with the code for the video and UI being tightly interlaced with it. What I'm wanting is to do is to upgrade the kernel and any drivers just enough to recognize the 865 chipset and not break the system. Sorry for the confusion.
Statistics prove that people who have more birthdays live longer.
Post Reply Post Reply


#7
I'm running Debian 8 Jessie on an M4A785-A mb circa 2006 (I think). The kernel is 3.16.0-4-686-pae. The mb has two PCI slots, so the kernel still supports them. I'm not sure how much the libc changes with new kernels, so I wonder if newer libc's might cause more problems than the kernel. You would probably want to compile your own kernel with minimal stuff. Can you recompile your video programs if you have to?
Post Reply Post Reply
#8
I contacted the software manufacturer to see if they had an upgrade or solution. They advised that it would be less expensive for me to purchase a new security DVR or use Zoneminder than anything they could sell me.

Thanks for letting me use you all as a sounding board.
-Red
Statistics prove that people who have more birthdays live longer.
Post Reply Post Reply
#9
Have you thought about virtualizing with one of the older editions of VMware so that the VM handles the underlying chipset to manage the interrupts and service calls? We had a similar problem with upgrading a legacy system using a D875PBZ Intel MOBO and Pentium 4 CPU and nothing worked until we tried virtualizing. We finally bit the bullet and replaced the entire system as it became insane to keep up with security patches even though our system was behind the DMZ and protected by NAT.
"The object in life is not to be on the side of the majority, but to escape finding oneself in the ranks of the insane." -- Marcus Aurelius
Post Reply Post Reply




Possibly Related Threads...
Thread Author Replies Views Last Post
  iOS 10 out tommorrow -- upgrade an iPhone 6? justMongo 25 1,065 09-18-2016, 01:26 PM
Last Post: AlanE
  Upgrade to El Capitan? 49er 31 2,759 01-25-2016, 12:52 PM
Last Post: Homerec130
  I am 'anemic'. Any tips or ideas, thoughts? Peter_C 42 6,809 01-27-2014, 02:43 PM
Last Post: Peter_C

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.