Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account



My ICON seems to be louder
#1
Been a while since i been on. Got my ICON last may and its now appears the motor is alot louder when using now then it did. Is that normal?????

Message me and i can hopefully send you a clip of what it sounds like.
Reply
#2
(03-06-2014, 09:51 PM)Tommy012175 Wrote: Got my ICON last may and its now appears the motor is alot louder when using now then it did. Is that normal?????
This should not happen so soon. Your machine is less than a year old, still under the two years warranty, ask for a replacement

Reply
#3
First check to make sure everything is attached and working correctly.

Mask and mask parts
Hoses - mask and main hose
Check and change filter
Ensure filter cover is in place right

Etc etc

If everything is working right, then make sure the noise is coming from the machine and not the mask. Sometimes the echo in the hose makes it sound as if it is the machine when it is not. Doesn't happen often, depends on the noise and the mask.

After that, discuss it with the DME. It should still be under warranty.
PaulaO2
Apnea Board Moderator
www.ApneaBoard.com


Breathe deeply and count to zen.

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.




Reply


#4
Yup, has the filter been changed recently? It's pretty small and thus tends to need frequent changing... especially in a dusty or carpeted environment.
Reply
#5
Quote:Got my ICON last may and its now appears the motor is alot louder when using now then it did. Is that normal?????

Ok, a possible cause for your Icon sounding loader is because the cover of the humidifier is not seated properly. This video shows how to fit the cover. I had this experience when I didn't refit the cover correctly. This image shows my Icon with cover not fitted properly[Image: icon.jpg]

[Image: signature.png]Keep on breathin'
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Icon and Sleepy Head issue remltr 5 176 01-15-2017, 08:14 AM
Last Post: remltr
  Icon+ Won't Write to USB Arend 2 247 11-05-2016, 02:32 AM
Last Post: PsychoMike
  Icon Premo not recording data Veracityau 3 223 10-26-2016, 10:12 PM
Last Post: Veracityau
  Pleas help does anyone use a F&P Icon 0rangebear 3 510 09-05-2016, 06:12 PM
Last Post: 0rangebear
  ResMed 10 Autoset v F&P Icon davidb01 5 823 05-06-2016, 05:03 PM
Last Post: zonk
  F&P ICON+ Boost Setting gpsgeek 2 586 04-29-2016, 07:47 PM
Last Post: trish6hundred
  [Equipment] Fisher & Paykel Icon+ questions kowlooner 9 1,089 04-28-2016, 12:24 AM
Last Post: Arend

Forum Jump:




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.