Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

My cpap is suddenly not working correctly
#1
Angry 
I have a philips dreamstation cpap machine. Last night I put the mask on and turned it on and it was very loud and very little air was coming through the tube. I can feel air coming to my mask, but it's extremely weak. I changed the filters and that didn't work either. This morning I put a new tube in and nothing. I've tried pretty much everything I can think of and am beyond frustrated. I called the place I got it from and am waiting to hear back from them.

Has anyone ever had this issue before and if so how do I fix it?
Post Reply Post Reply



Donate to Apnea Board  
#2
Haven't had anything like that happen yet but; thinking about how it is designed, I wouldn't be surprised if the humidifier seal got somehow out of place. Have a look there. Have you tried to disconnect the humidifier and run the hose directly from the machine?
Everything I post on this board is nothing more than an opinion expressed by an apneak. Normally, it's based on facts and experience but sometimes, I may get things wrong or not have all the facts.
I reserve the right to change my mind. Why? Because tomorrow I may know better.
Post Reply Post Reply
#3
Not much in the path of the air if the blower is working correctly.
make sure the humidifier is all sealed up, gasket in place, as above the machine connection.
also make sure the mask anti-asphyxiation valve isn't stuck and blocking the air flow.
take the mask off the hose and stuff something in the hose to mostly plug it and see if you feel or hear where the air is leaking from.
Post Reply Post Reply
#4
"also make sure the mask anti-asphyxiation valve isn't stuck and blocking the air flow..."
Not to be picky, the anti-asphyxiation valve fails in the open mode, venting flow out a big hole.

You might try the hose in the kitchen sink method of checking pressure.
Although you are concerned about air flow; if the cause is some large leak like the humidifier, the machine probably cannot come up to pressure.

Admin Note:
JustMongo passed away in August 2017
Click HERE to read his Memorial Thread

~ Rest in Peace ~
Post Reply Post Reply
#5
[hopefully its still under warranty, check both power cord connections and thaqt its on the correct voltage
Post Reply Post Reply



Donate to Apnea Board  
#6
Hi oregon97232,
WELCOME! to the forum.!
You did the right thing by calling the place where you got your machine. Since you havent had it too long, it is still under warranty.
Much success to you with your CPAP therapy and getting a machine that works.
trish6hundred
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [CPAP] Choosing and working with a DME: A Beginner’s Dilemma BostonPH 27 1,111 04-18-2018, 01:29 PM
Last Post: OpalRose
  Dreamstation suddenly too loud and with too much pressure smsilverstein 21 2,225 04-10-2018, 12:22 AM
Last Post: Mark26
  How to know if heated tube is working oldfart59 14 440 03-10-2018, 12:53 PM
Last Post: JesseLee
  Leaking: long time user suddenly unable to diagnose and solve leak issue(s) Sora 15 629 02-26-2018, 09:44 PM
Last Post: BAZZA
  Is my ResMed AirCurve 10 working correctly? oldfart59 11 701 02-04-2018, 03:11 PM
Last Post: oldfart59
  Is my humidifier working? ResMed AirCurve 10 oldfart59 5 342 01-22-2018, 12:33 PM
Last Post: Sleep2Snore
  Is my dreamstation humidifier working? ghstudio 5 1,080 01-01-2018, 04:53 AM
Last Post: bspengler

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.