Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Oops Devilbiss Standard Plus got wet...problems?
#1
Oops Devilbiss Standard Plus got wet...problems?
Hello. I've been using the Devilbiss Intellipap Standard Plus for about 2.5 years. Recently, I traveled overnight and forgot to take all of the water out of the humidifier. When I opened up the case the unit was a bit damp. Not soaked, just damp.

I dried it off as best I could and then let it sit. I finally plugged it in and it worked, but seemed to be malfunctioning. It would blow hard and then soft and start on it's own. I shut it off and hoped that it might dry out and work again.

I got it to work again and it seems to be ok with a few exceptions. The "auto on" feature does not work. I can't simply put on the mask and start breathing.

Also, I had trouble with the Flexsmart feature in that it didn't seem to be cycling like usual. I went through the settings (and the clinician's set up menu) and turned it off. I unplugged it and then waited. Plugged it back in and then set the menu to "on" for the Flexsmart feature. It's working correctly now, I think.

Questions:

1. Is there anything I can do to get the AutoStart feature to work?

2. Should I try a master reset to factory defaults? If so, how do I do that? I would have to write down all the current settings to make sure I get them right on the reboot.

3. What are all of the "ports" on the back of the unit? The small square one in the middle looks like it could be a reset button, but I'm not sure.

Any help greatly appreciated.

AR
Post Reply Post Reply






Donate to Apnea Board  
#2
RE: Oops Devilbiss Standard Plus got wet...problems?
Hi artmanr,
WELCOME! to the forum.!
I'm not familiar with your machine but hang in there and someone will be able to help you soon.
Best of luck to you.
trish6hundred
Post Reply Post Reply
#3
RE: Oops Devilbiss Standard Plus got wet...problems?
Artmanr, have you contacted the DME to see what they recommend? Have you looked in our Clinician's Manuals Section to see if your machine's manual is available?

Manuals are found here:
http://www.apneaboard.com/adjust-cpap-pr...tup-manual
INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. 
ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA.
Post Reply Post Reply
#4
RE: Oops Devilbiss Standard Plus got wet...problems?
Professional cleaning needed?
"With ordinary talent and extraordinary perseverance, all things are attainable." - Thomas Foxwell Buxton

Cool
Post Reply Post Reply






Donate to Apnea Board  


Possibly Related Threads...
Thread Author Replies Views Last Post
  fl runs+ breathings problems Gorge 0 154 05-25-2022, 05:19 PM
Last Post: Gorge
  New CPAP User - Having Problems bigtimesnorer 1 241 05-09-2022, 06:43 PM
Last Post: Big Guy
  [Health] breathing problems Gorge 6 320 04-30-2022, 06:08 PM
Last Post: Gideon
  Devilbiss Intellipap disassembly REMember 5 225 03-31-2022, 07:27 AM
Last Post: REMember
  [split] Bleep Sleep Mask - Attaching Problems Steptoe 2 219 03-14-2022, 12:52 PM
Last Post: SleepyDwarf123
Grin ResMed Airsense 10 Autoset Problems Lahanna44 46 65,273 03-07-2022, 05:15 PM
Last Post: OpalRose
  Problems since cpap auto shut off seamusv 17 727 01-31-2022, 10:33 PM
Last Post: DaveL


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.