Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Oscar on Linux Mint
#1
Oscar on Linux Mint
I am currently using Mint 18.3.  Oscar won't install as it is looking for some dependencies. It starts with libdouble-conversion3.   I am considering upgrading to Mint 20 as the end of support for 18 is coming up . Has anyone have any experience with Mint?  Presently I am using a Raspberry Pi for Oscar.
Thanks
Roger
Post Reply Post Reply






Donate to Apnea Board  
#2
RE: Oscar on Linux Mint
You might try this.  
In a terminal window, type or copy: sudo apt-get install gtkhash libb2-1 libqt5opengl5 libqt5serialport5 libqt5printsupport5 libqt5xml5.  

Here is the Wiki link to installing OSCAR on Linux - http://www.apneaboard.com/wiki/index.php...ion:_Linux

I have upgraded 2 of my computers from LM 19.3 to LM 20.  You will need to reinstall the OSCAR_1.1.1_Ubuntu_20.04_amd64 version after the upgrade.
Crimson Nape
Apnea Board Moderator
www.ApneaBoard.com
___________________________________
Useful Links -or- When All Else Fails:
OSCAR Chart Organization
Attaching Images and Files on Apnea Board
Beginner's Guide to Sleepyhead and OSCAR
Apnea Helpful Tips

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.
Post Reply Post Reply
#3
RE: Oscar on Linux Mint
Thanks for the reply.  Unable to locate package by glob 'libqt5xml5    It may not be available for mint 18  I probably will be upgrading to LM20 fairly soon. 
Roger
Post Reply Post Reply
#4
RE: Oscar on Linux Mint
I might have not listed all of them. You could try: dpkg-deb -I OSCAR_1.1.1_Ubuntu_18.04_amd64.deb This should show the dependencies for you. What command are you using for the install command?
Crimson Nape
Apnea Board Moderator
www.ApneaBoard.com
___________________________________
Useful Links -or- When All Else Fails:
OSCAR Chart Organization
Attaching Images and Files on Apnea Board
Beginner's Guide to Sleepyhead and OSCAR
Apnea Helpful Tips

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.
Post Reply Post Reply






Donate to Apnea Board  
#5
RE: Oscar on Linux Mint
using  sudo apt install ./oscar_1.1.1-Ubuntu18_amd64.deb  the results are

 oscar : Depends: libdouble-conversion1 but it is not installable

         Depends: libqt5core5a (> 5.9) but 5.5.1+dfsg-16ubuntu7.7 is to be installed

Using the GDeb  package installer it reports "Dependency is not satisfiable: libdouble-conversion1

At this point I may just use the Raspberry computer and switch the monitor around to be more convenient.    It's been a while since I've chased after this stuff. I'm retiring soon and will be able to devote more attention to these things again.

Thanks so much
Post Reply Post Reply
#6
RE: Oscar on Linux Mint
The Debian9 OSCAR .deb package was built with qt 5.7, and that is the lowest version that will compile. Ubuntu 18.04 uses qt 5.9, the current debian Buster version uses qt 5.11.

I am investigating the use of AppImage packaging, but you will probably have upgraded by the time that is ready.
Apnea Board Monitors are members who help oversee the smooth functioning of the Board. They are also members of the Advisory Committee which helps shape Apnea Board's rules & policies. Membership in the Advisory Members group does not imply medical expertise or qualification for advising Sleep Apnea patients concerning their treatment.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Sad Oscar Freezes on Debian Linux (Buster) 10.4 Gooserider 16 436 07-18-2020, 04:00 PM
Last Post: Gooserider
  Linux, OSCAR, on a Dell Latitude E6510 Sleepster 13 298 06-24-2020, 02:32 PM
Last Post: Crimson Nape
Question Compatibility of OSCAR data between Linux and Windows Sn00zeAlarm 1 157 04-15-2020, 05:11 PM
Last Post: Crimson Nape
Sad OSCAR - Linux Mint 19 [see post #7 for solution] Marcch 37 2,000 04-01-2020, 01:45 PM
Last Post: Crimson Nape
  FlashPAP Producing Odd Status During A10 Download in Linux Crimson Nape 13 316 02-18-2020, 06:02 PM
Last Post: sawinglogz
  Oscar Installation on Chromebook Linux spmcg 4 383 02-15-2020, 08:31 AM
Last Post: mjphyi
  OSCAR Installation issues [on LInux] gawdly1 8 335 02-11-2020, 10:29 PM
Last Post: pholynyk


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.