Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Oximetry Error in OSCAR
#1
Oximetry Error in OSCAR
Hi,

I periodically run a oximetry check while on APAP. At the time of the last run, I started and stopped both the machine and oximeter at roughly the same time. When I transferred the oximetry data into OSCAR, the last one plus hour was not included. The stop time agrees when viewed in the SpO2 Assistant software s well as the stop time listed in the associated CSV file. See the attached file.

Can someone suggest what might be going on here?


Attached Files Thumbnail(s)
   
Post Reply Post Reply






Donate to Apnea Board  
#2
RE: Oximetry Error in OSCAR
Unfortunately, I can think of several things...

Fist I calculated the percentage difference in duration as 15%. This much error would likely rule out some of the possibilities.

One possible error is sampling rate; OSCAR assumes once per second. Too slow a sampling rate would create a shorter duration record. (15% is a huge rate error, not likely the problem here)
Another possibility is dropping data during the import; this is dependant on the operating system and what else it may be doing, as well as the design of the import software. Have you tried importing using Contec's SpO2 Assistant as well as OSCAR's direct import? They should report the same duration...
It is also possible there was an error during the conversion from the sample per second data imported to the time-delta format used by OSCAR's database format.

The last, which processes data in chunks, seems the most likely culprit, given the large error, and that I have seen duplicated SpO2 data occasionally. I will make a note in the Mantis issue tracker about lost and duplicated data during conversion.
Apnea Board Monitors are members who help oversee the smooth functioning of the Board. They are also members of the Advisory Committee which helps shape Apnea Board's rules & policies. Membership in the Advisory Members group does not imply medical expertise or qualification for advising Sleep Apnea patients concerning their treatment.
Post Reply Post Reply
#3
RE: Oximetry Error in OSCAR
Thanks for your thoughts on this. The associated oximetry CSV file shows sampling occurs every second. Also, I imported the data into OSCAR directly as well as through SpO2 Assistant, with the same results.

This was the first time I'd seen this. All prior imports into OSCAR were done without issue.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  ResScan 5.9 Failed to Apply Settings error [resolved, see post #2] jamesj 3 172 09-15-2020, 11:11 AM
Last Post: jamesj
  OSCAR-oximetry data import record/file layout jtmAZ 47 2,396 07-28-2020, 02:12 PM
Last Post: sawinglogz
  Oscar reporting questions Daily vs Statistics Oximetry snowydon 0 198 06-08-2020, 03:16 PM
Last Post: snowydon
  importing oximetry in Oscar problems. car54 33 1,846 05-13-2020, 03:50 PM
Last Post: PhoebeAnn
  Take Screenshot F12 (ERROR) BrassCat 10 402 04-09-2020, 08:02 PM
Last Post: DeepBreathing
  Pulse oximetry with Rescan jmayer180 4 300 03-08-2020, 07:50 PM
Last Post: DeepBreathing
Sad Oscar kills the Ubuntu VM it is running in [solved: bug in VirtualBox, not OSCAR] fredex 1 372 12-16-2019, 08:47 PM
Last Post: fredex


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.