Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account

New Posts   Today's Posts

PLEASE PLEASE Help me! [Pulse Oximeter issues]
Hello everyone.

I really hope that someone can PLEASE help me!!!!

I have just got a Pulse Oximeter, a Contec CMS 50D+.

It works great on my finger, BUT - you guessed it - I am having trouble with the software, and REALLY need someone's help; I've tried EVERYTHING!!!

I am running Windows 7 Pro. I had to download the software, as ,y laptop has no drive for discs at all.
The download was easy. I followed the instructions, re-started the laptop, and so on, and I now have a Red Heart Shortcut Icon (called SpO2), and a Green Heart Shortcut Icon (SpO2 Review) both on my desktop.

If I have understood correctly, the red icon is to provide a real-time display of what the finger probe is picking up, and the green icon is to look back and analyze data that the probe has recorded, for example over night.

I have only tried the RED icon so far. Double-clicking on it brings up a lovely, professional looking screen showing a graph, with either one or four panes, if I double-click. On the left, the Y-Axis (up/down) says Sp02%. on the right hand side, the Y axis says pulse (bpm).

BUT I can't get any readout at all!!! The probe is working perfectly on my finger. And in "Control Panel" -> "View Devices and Printers", when I plug in the USB cable from the finger probe, it makes the "ding" sound to recognise it, and an icon appears, but that's it!! I can never get it to "start up", sort of thing!!

I have tried all different combinations, rebooting, turn on probe before inserting USB Cable, then other way round, etc etc, all combinations. And I cannot seem to see anywhere, an icon to click on to "start" the real-time transfer and display...

Am I missing something really obvious?? someone PLEASE help, I'm going crazy!!!

Help or suggestions would make me sooooo happy!!!
Thank you, everybody!!!

Post Reply Post Reply

Donate to Apnea Board  

Try the above wiki article

Admin Note:
JustMongo passed away in August 2017
Click HERE to read his Memorial Thread

~ Rest in Peace ~
Post Reply Post Reply
Hello justMongo,

Thank you for your reply. Unfortunately, still no luck!!! I still have both green and red Heart Icon on my Desktop, an I can open them fine, but still now, when I open the icon to view real-time data from my 50D+, the black empty Graph Screen opens. The USB Cable is attached (and it makes the "ding" sound, as though it has recognised it), I turn it on, insert finger, and wait..... Nothing Happens!!! Also in the bottom left corner next to the 1, 2, 3, 4 Boxes, it reads: <1>: Not Active. (Or the same for 2, 3 and 4). So I'm still lost!!

I will keep trying, but thank you nonetheless for your suggestion.

Any other ideas are very welcome!!


Post Reply Post Reply
Have you look in device manager to make sure there isn't a driver issue? Start > Run and type in devmgmt.msc
Run it first without the cable attached and then while you have device manager open attach the cable so you can see the device appear.

If that looks fine, right click your SpO2 Review icon and run as administrator to eliminate permission issues.

Using FlashAir W-03 SD card in machine. Access through wifi with FlashPAP or Sleep Master utilities.

I wanted to learn Binary so I enrolled in Binary 101. I seemed to have missed the first four courses. Big Grinnie

Post Reply Post Reply
YES!!! AlanE thank you so much, you saved the day!!

In device manager, it showed up but as having no driver, so I went and re-downloaded it, and, hey presto!! all looks good!

Thanks so much for your help.
Post Reply Post Reply

Donate to Apnea Board  
You're welcome. Good luck.


Using FlashAir W-03 SD card in machine. Access through wifi with FlashPAP or Sleep Master utilities.

I wanted to learn Binary so I enrolled in Binary 101. I seemed to have missed the first four courses. Big Grinnie

Post Reply Post Reply

Possibly Related Threads...
Thread Author Replies Views Last Post
Exclaimation More SvO2 A$$t/CMS50F 'issues' -- missing session ShaunBlake 9 95 03-21-2018, 09:55 PM
Last Post: ShaunBlake
  SleepyHead - imported oximeter messed up the graphs MyronH 2 228 02-18-2018, 09:10 AM
Last Post: Walla Walla
  Sleepyhead with Masimo Radical 7 Oximeter cbr1 2 365 02-13-2018, 01:32 PM
Last Post: bsmorgan
  Problems with SP02 Assistant v 3.0.4 not recognising Oximeter Contect CMS50E MaxHatman 4 425 01-01-2018, 05:43 AM
Last Post: MaxHatman
  SleepyHead..removing pulse ox data Allessio77 5 283 12-09-2017, 10:47 AM
Last Post: Sheepish
  CMS50F v3.9 Pulse Oximeter c2workout 11 1,532 09-19-2017, 12:00 PM
Last Post: fog.apnea
  Sleepyhead CMS50D+ Import Issues oz02 5 1,583 09-18-2017, 11:49 AM
Last Post: pholynyk

Forum Jump:

New Posts   Today's Posts

About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.