Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Problems importing data on new sleepyhead installation
#1
Hi I have recently reinstalled Sleepyhead after having used it successfully some time ago.
I had a hard drive failure and so changed to a new one.
I didn't have any need to use Sleepyhead so didn't install it until now.
I downloaded the latest version 1.0.0-beta-2 and it installed with no problems.
My operating system is Windows 7 64 bit
However, when I try to install my data from my SD card I get the following error

"This application has requested the Runtime to terminate it in an unusual way.

Please contact the applications support team for more information."

I have tried setting up a alternative profile,
I have removed and reinstalled the  Sleepyhead software.
I have rebooted the computer after the reinstall (even though the software installation procedure didn't prompt me to do so).
I have looked at the options in the Sleepyhead preferences but I have not changed anything in there as I cant see anything that appears to be relevant to my issue.

So far I am unable to complete the data download.

Some times the message comes up at about the 60 percent mark of the data download. The program then forces me to shut it down.
When I restart the process it goes along much faster till it get to the point where it crashed, then it continues slowly till it gets to the 99% mark.
Then the error message comes up again.
and I'm forced to close the program.

I have been using this machine (and the SD card) since 2013.
I can see the dates for the data on the card in Windows Explorer. So there is a lot of data.
Windows Explorer Properties tells me that there is 214MB of data (used space) but it also shows that there is still 1.54 GB of free space on the card.
I would appreciate any suggestions of what I can try to make this work.
Kind Regards,
Paul
Post Reply Post Reply
#2
I clicked in the "More Details" link in the error message and I got this information...
"Problem signature:
Problem Event Name: APPCRASH
Application Name: SleepyHead.exe
Application Version: 0.0.0.0
Application Timestamp: 064d0b28
Fault Module Name: libstdc++-6.dll
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 00000000
Exception Code: 40000015
Exception Offset: 0001f11d
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 3081
Additional Information 1: dc8a
Additional Information 2: dc8ad7a8eb7c2f8a7d94c2a90427ee9c
Additional Information 3: e47a
Additional Information 4: e47a374045cafcc25fc0980fc77e5b2f"
Post Reply Post Reply
#3
Hi AussiePaul - Welcome

You may be missing a Microsoft Visual C++ Runtime library dll.  Here is a link to the available libraries from Microsoft:
https://support.microsoft.com/en-us/help...-downloads

I hope this will help.
______________________
Useful Links -or- When All Else Fails:
Posting SleepyHead Charts in 5 Easy Steps
Robysue's Beginner's Guide to Sleepyhead
Apnea Helpful Tips
Post Reply Post Reply


#4
Hi! Thanks for the welcome and the reply. I tried downloading the latest Runtime... and the two previous ones as well, but nothing changed.
I have tried several re- installs but still nothing has changed.
Happy to try any other suggestions because I'm at a loss here at the moment.
Cheers,
Paul.
Post Reply Post Reply
#5
which ones exactly did you try to install? (really try to be as specific as possible like: the first one from the "Visual Studio 2013 (VC++ 12.0)" )

Try this one: https://www.microsoft.com/en-us/download...x?id=40784
and you have to choose the "vcredist_x86.exe" (yes you have a 64Bit OS but SH is compiled for 32bit - which is no issue at all - but you really need the corresponding runtimes) ... or take them both - but make sure, you get the 32bit version as well! (in a few weeks you have them either way as they are installed by enough programs)

(If I remember correctly SH and the corresponding QT-version both used the VS2013 runtimes)
Post Reply Post Reply
#6
(02-15-2017, 03:55 AM)TBMx Wrote: which ones exactly did you try to install?
Hi TBMx,
I installed "Microsoft Visual C++ Redistributable Packages for Visual Studio 2015 Update 3 first.

I figured that the latest would have everything that was relevant from earlier.

Then when that made no difference, I tried Microsoft Visual C++ Redistributable Packages for Visual Studio 2013, and then

Microsoft Visual C++ Redistributable Packages for Visual Studio 2012 Update 4

I hadn't thought to try the X86 version but "SH is compiled for 32bit" makes sense so I did try that from the Microsoft Visual C++ Redistributable Packages for Visual Studio 2013  and still the same result.

I may have inadvertently misled you about my Windows installation.
This is not a recent install.
I changed to the new hard drive on 05/Dec/2015.
I just have not needed to have SH software on it since I did the install, so I have not put it on.
I have decided recently that I'd like to have a look at my recent data and hence the reason for now wanting it back on.

I would have thought all of these Runtimes would have been on anyway as a part of the software I have installed over the year or so since I went to the new hard drive.
Thanks for your assistance in this.
Kind regards,
Paul.
[url=https://support.microsoft.com/en-us/help/3179560][/url]
Post Reply Post Reply


#7
I thought it might be helpful to display all of the Redistributable Packages I have on my computer including the version numbers.
Thank you again for taking the time to help me.
Cheers,
Paul



[Image: 012efc720360fda9d9a349faaf8628fe.jpeg]
Post Reply Post Reply
#8
welll .... early in the morning ... should have read your error-message completely ... it's not a MS-VC problem it is with minGW / gcc (which seems to be used by jedimark rather than VS2013)
that's really odd because the neccessary libraries are included in the installer - I just double checked that.

did you ran the installer with "admin-priviliges" aka right click on it and than "run as admin"? If not - try that!
and did you change the installpath? (or have moved the system-default-paths?) if so: use the default ones!

if that doesn't help either: basically your system is screwed somewhere ... do you have by any chance eclipse / mingw / gcc or some other compiler on your system? (or some really scary drivers?) ... I would suspect another library in your path-environment or the systemfolders, which has the same filename but is not the same version. (does not necessarily need to be the libstdc++) .. or maybe your WOW (windows on windows) is messed up.

you could try and repair that by hand - just google for the libstdc++-6.dll ... mess around with the dependcy-walker-tools ... the one in the sleepyhead install folder is the one you want to use^^ (and be prepared for the total-windows-DLL-Hell to rain down on you^^)

in the end it might be easier to just grab a virtual PC copy of windows 7 or 10 (MS has enough ready-to-use for free download with a 30-day-trial) and run SH from there^^

EDIT: if you - in the end - manage to get SH working, it would be nice for others with the same problem, if you could share your solution.
Post Reply Post Reply
#9
Hi TBMx Thanks  once more for the reply.

On at least 2 of the times I tried to reinstall SH (out of probably 5  now) I did try running as administrator.
Made no difference.

I have never changed the install paths from the defaults... or the system-default-paths.

"do you have by any chance eclipse / mingw / gcc or some other compiler on your system?"
Not that I am aware of.
I don't do any compiling so I can't see anyway it would be.
"(or some really scary drivers?)"
I really don't think so... but I'm not sure just what a "really scary driver is"

"you could try and repair that by hand"
I think that would be  a bit of an over reach for my capabilities.

"might be easier to just grab a virtual PC copy of windows 7"
I do have a Virtual Machine set up on this computer. "Oracle VM VirtualBox"
I have only used it once, just out of interest, but that would be an option.

I also have a laptop that I tend to only use when I want a portable computer, but I could just put SH on there.

"... share your solution."
I agree, however I think I have probably gone as far as my trouble shooting on this is going to go, not because I'm not interested, but because I realize I'm probably going to have to exceed my levels of expertise far beyond where I would feel comfortable, if I were to continue.

I think I'll try the VM later today.
(As I said, it's already installed)... only needs a click on an icon and it can be running, then install SH on that.

If that turns out to not be suitable, for what ever reason, I'll fire up the laptop and install SH on that.
Thanks again for your help.
I'm off for my morning swim now.
All the best,
Paul
Post Reply Post Reply


#10
For giggles, did you try running the broken GL version of SH? It's in the install directory.


Using FlashAir W-03 SD card in machine. Access through wifi with FlashPAP or Sleep Master utilities.

I wanted to learn Binary so I enrolled in Binary 101. I seemed to have missed the first four courses. Big Grinnie

Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Cool Historical Sleepyhead data looks strange after travel to different timezone vas2000 11 550 10-20-2017, 11:54 AM
Last Post: Sheepish
  Can SleepyHead export time series data as CSV? rbookman 5 304 10-16-2017, 03:00 AM
Last Post: TBMx
Cool Recommendation: FlashAir and Flashpap - Wifi data transfer from CPAP to PC/Sleepyhead mogulman 26 1,006 10-09-2017, 05:52 PM
Last Post: Crimson Nape
  Sleepyhead Overview Graphs Missing Data Points Hojo 9 182 10-09-2017, 04:18 PM
Last Post: srlevine1
  SleepyHead Install Problems dancoate 6 157 10-09-2017, 01:17 PM
Last Post: dancoate
  Sleepyhead crashed before data upload finishes ScottGA 6 773 10-06-2017, 11:53 AM
Last Post: pholynyk
  Sleepyhead data import note changes Bripin 8 495 09-05-2017, 01:55 PM
Last Post: AlanE

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.