Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

ResMed S9 problems
#1
Unit was working great. Went to turn it on and no air comes out. Got power. Checked all connections. Still no airflow. Please help
Post Reply Post Reply
#2
(07-23-2015, 11:31 AM)gloss1 Wrote: Unit was working great. Went to turn it on and no air comes out. Got power. Checked all connections. Still no airflow. Please help


I'm not very tech savvy, just a few suggestions.
Try unplugging it, wait a few minutes, then plug in again.
Do the filters need changed?
How old is the machine?
Is it still under warranty?
Post Reply Post Reply
#3
(07-23-2015, 11:36 AM)OpalRose Wrote:
(07-23-2015, 11:31 AM)gloss1 Wrote: Unit was working great. Went to turn it on and no air comes out. Got power. Checked all connections. Still no airflow. Please help


I'm not very tech savvy, just a few suggestions.
Try unplugging it, wait a few minutes, then plug in again.
Do the filters need changed?
How old is the machine?
Is it still under warranty?

Tried all of this but still no air. I have a feeling its broken. The kids may have knocked it off of the nightstand
Post Reply Post Reply


#4
is humidifier lid closed securely?
Post Reply Post Reply
#5
Hi gloss1,
WELCOME! to the forum.!
If it were knocked off the nightstand, hopefully your machine didn't get water damage.
Hang in there for more suggestions and answers to your questions.
Much success to you with getting your machine straightened out and with your CPAP therapy.
trish6hundred
Post Reply Post Reply
#6
Usually, error message displayed on the screen telling you of the problem
Did you also checked the plug fully inserted into the back of the machine?



Post Reply Post Reply


#7
(07-23-2015, 05:43 PM)zonk Wrote: Usually, error message displayed on the screen telling you of the problem
Did you also checked the plug fully inserted into the back of the machine?

I actually do not have the humidifier part hooked up. Very well plugged into the back. Have checked it several times. Thanks so much
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Bipap AVAPS problems samianwardcummings 10 362 03-24-2017, 07:12 AM
Last Post: Sleeprider
  Problems with AirFit P10 Nasal Pillows (+ResMed AirSense 10) numari 18 7,033 03-23-2017, 11:36 AM
Last Post: PaytonA
Angry So I just had words with my DME @ Pacific pulmonary problems MzRobin28 4 196 03-08-2017, 10:40 PM
Last Post: MzRobin28
  Vertigo/CPAP Pressure Update- CPAP causing inner ear problems SuperSleeper 70 67,559 03-05-2017, 08:26 PM
Last Post: Melman
  nuance to Swift FX for her setting problems akdog30 11 362 02-11-2017, 11:18 AM
Last Post: Ghost1958
  S9 presssure problems E.W. 7 325 01-14-2017, 09:43 AM
Last Post: E.W.
  Problems with my humidifier settings...... binky12 9 618 01-02-2017, 06:20 PM
Last Post: binky12

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.