Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Respironics System One A-Flex, blower won’t start, Beep Beep Alarm, “Service Required
#1

The Problem:
1.Blower won’t start, alarm sounds, see “Service Required” in display window
2.Sound asleep, blower stops, alarm sounds, see “Service Required” in display window

The Solution:
1. I did both of these things at the same time so, one or both solved the problem.
a. Took hose filter and intake filter off the system
b. Took memory card out and cleared the memory on the card
c. Put clean filters back on the system

CPAP has worked fine for a week now. THANK YOU TO THE PEOPLE WHO POST ON THIS BOARD. Even the ones who send you down the rabbit hole to look for Alice!
Post Reply Post Reply
#2
Hi rae95131,
WELCOME! to the forum.!
It's good to hear that your machine is working now and I hope it continues.
Good luck to you as you continue your CPAP therapy.
trish6hundred
Post Reply Post Reply
#3
Welcome to ApneaBoard rae95131 ! Glad you were able to fix your problem!
APNEABOARD - A great place to be if you're a hosehead!! Rolleyes

-------------------------------------------------------------------------------------------------
EVERY ACCOMPLISHMENT BEGINS WITH THE DECISION TO TRY!
Post Reply Post Reply


#4
Hi everybody,

Ihave been successfully using system one Philips c flex for almost 2 years.
Lately, my machine started creating problems .
Last few nights, my cpap suddenly stopped for seconds then resumed back for few minutes then started beeping (alarm with blinking light) then totally stopped with the screen indicating SERVICE REQUIRED , I then unplugged the electrical cord then re-connected it then machined started , for few minutes though then stopped again!!!I changed the filters, removed memory card, changed my full mask, but problem persists.
I'm unable to use my machine as a result.

I seek your kind advice if anyone comes across same issue.
Post Reply Post Reply
#5
Almost two yrs?.
Send it in to PR. PR machines have a two yr warrenty
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Anyone start on CPAP and then add oxygen...? S.L. Ping Beauty 8 114 08-18-2017, 04:43 PM
Last Post: Walla Walla
  [Admin Note] WANTED: CLINICIAN SETUP MANUAL for 60-series PR System One REMstar Plus w/ C-Flex SuperSleeper 1 84 08-17-2017, 07:11 PM
Last Post: Galactus
  [CPAP] Guidance required, 10+ months and no progress! antstephenson 9 164 08-17-2017, 03:53 PM
Last Post: trish6hundred
  Service required kennmcb 8 326 08-17-2017, 12:46 PM
Last Post: kennmcb
  Resmed S10 Airsense vs. Respironics Dream Station Weird Tolkienish Figure 128 45,852 08-16-2017, 02:20 AM
Last Post: JeffT
  [CPAP] Respironics M-Series BiPap Auto Question Dawnstar 6 146 08-13-2017, 09:15 PM
Last Post: Sleeprider
  [Equipment] Respironics BiPap A40 petnew 2 104 08-10-2017, 10:12 PM
Last Post: Sleeprider

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.