Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

S9 humidifier problem
#1
Been using the S9 happily for two years now. I just realized that for the last two days the humidifier isn't working at all. I have a 2 year-old who might have been playing with it and pressed buttons that shut it off. I can't figure it out, and there's no troubleshooting FAQ anywhere. Anyone been in this situation?
Post Reply Post Reply
#2
Hi johnmordecai
Check the S9 and the humidifier connected correctly
Press the black release button to disconnect the S9 and the H5
align them again and push them together until they click in place and the humidifier blue light should comes on
otherwise you might try to have it replaced under the 2 years warranty



Post Reply Post Reply
#3
(05-18-2012, 04:16 AM)johnmordecai Wrote: Been using the S9 happily for two years now. I just realized that for the last two days the humidifier isn't working at all. I have a 2 year-old who might have been playing with it and pressed buttons that shut it off. I can't figure it out, and there's no troubleshooting FAQ anywhere. Anyone been in this situation?

Welcome to Apnea Board, John!

If you need the Clinician Manual for the S9 unit, you can request it by following the directions in Section Three of this page:

http://www.apneaboard.com/adjust-cpap-pr...tup-manual

That manual also includes the manual for the H5i Humidifier, which may help you a bit.

SuperSleeper
Apnea Board Administrator
www.ApneaBoard.com


INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.



Post Reply Post Reply


#4
Ha! I was having same problems (2 year old and all). Been looking for solution til I read this. I took the advice of disconnecting the cpap from the humidifier and reconnecting. It worked and made me feel dumb for not trying it sooner. Goooooodniiiigh...... Zzzzzzzzzzz.... Zzzzzz....
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  dreamstation and p10 noise w/o humidifier porsche987 11 324 01-13-2018, 09:35 AM
Last Post: porsche987
  How to Keep Nose Open at Night?/Humidifier Defective? bluemom51 8 193 01-11-2018, 07:11 PM
Last Post: bluemom51
  [CPAP] setting up S9 Escape Auto with H5i Humidifier RK Dutta 2 107 01-09-2018, 08:07 AM
Last Post: Walla Walla
  Is my dreamstation humidifier working? ghstudio 5 580 01-01-2018, 04:53 AM
Last Post: bspengler
  Medicare Problem? RLSdss 7 272 12-22-2017, 07:56 PM
Last Post: RLSdss
  [Symptoms] Hypopnea problem hkcl 3 210 12-21-2017, 02:53 PM
Last Post: Walla Walla
  AHI problem RLSdss 17 351 12-15-2017, 10:28 AM
Last Post: Sleeprider

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.