Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

S9 humidifier problem
#1
Been using the S9 happily for two years now. I just realized that for the last two days the humidifier isn't working at all. I have a 2 year-old who might have been playing with it and pressed buttons that shut it off. I can't figure it out, and there's no troubleshooting FAQ anywhere. Anyone been in this situation?
Post Reply Post Reply
#2
Hi johnmordecai
Check the S9 and the humidifier connected correctly
Press the black release button to disconnect the S9 and the H5
align them again and push them together until they click in place and the humidifier blue light should comes on
otherwise you might try to have it replaced under the 2 years warranty



Post Reply Post Reply
#3
(05-18-2012, 04:16 AM)johnmordecai Wrote: Been using the S9 happily for two years now. I just realized that for the last two days the humidifier isn't working at all. I have a 2 year-old who might have been playing with it and pressed buttons that shut it off. I can't figure it out, and there's no troubleshooting FAQ anywhere. Anyone been in this situation?

Welcome to Apnea Board, John!

If you need the Clinician Manual for the S9 unit, you can request it by following the directions in Section Three of this page:

http://www.apneaboard.com/adjust-cpap-pr...tup-manual

That manual also includes the manual for the H5i Humidifier, which may help you a bit.

SuperSleeper
Apnea Board Administrator
www.ApneaBoard.com


INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.



Post Reply Post Reply


#4
Ha! I was having same problems (2 year old and all). Been looking for solution til I read this. I took the advice of disconnecting the cpap from the humidifier and reconnecting. It worked and made me feel dumb for not trying it sooner. Goooooodniiiigh...... Zzzzzzzzzzz.... Zzzzzz....
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [Equipment] DreamStation Auto Humidification problem Giasdaddy2010 15 5,843 Today, 05:13 AM
Last Post: Healthkares
  Help me understand how humidifier levels are managed by the xPAP DanPrado 18 704 Yesterday, 10:33 PM
Last Post: Wolfram
  [Equipment] Respironics Remstar auto A- flex humidifier stopped working Reddog 4 91 Yesterday, 09:29 AM
Last Post: Sleeprider
  Humidifier Tub Looks Scorched CTcentrals 4 218 09-17-2017, 12:40 PM
Last Post: CTcentrals
Question [Pressure] New ResMed Airsense 10 Pressure Problem spookyac47 5 186 09-16-2017, 03:44 PM
Last Post: trish6hundred
  PR System One Humidifier Problem gludden 7 143 09-16-2017, 03:17 PM
Last Post: trish6hundred
  Advice Needed- Problem With Recording on the CMS 50D + Oximeter nico08 4 180 09-07-2017, 12:08 AM
Last Post: aquanaut20

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.