Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

SleepyHead 1.0.0 Linux
#21
Also running LinuxMint 17.3, I'm glad to hear there's a pathway. Now all I need is a new laptop - mine is only supported up to OpenGL 1.4, and I understand 2.0 is the absolute minimum there.
Post Reply Post Reply



Donate to Apnea Board  
#22
I think the euphamistically named 'brokengl' version will work with that older opengl.
Post Reply Post Reply
#23
(05-22-2016, 01:46 PM)wubisnotanabbreviation Wrote: Also running LinuxMint 17.3, I'm glad to hear there's a pathway. Now all I need is a new laptop - mine is only supported up to OpenGL 1.4, and I understand 2.0 is the absolute minimum there.

Easy enough. On the next to last command add
Code:
DEFINES+=BrokenGL

So...
Code:
$ sudo add-apt-repository ppa:beineri/opt-qt551-trusty
$ sudo apt-get update
$ sudo apt-get install qt55-meta-full
$ source /opt/qt55/bin/qt55-env.sh

$ cd ~
$ git clone https://gitlab.com/sleepyhead/sleepyhead-code.git sleepyhead-code
$ mkdir sleepyhead-build && cd sleepyhead-build
$ qmake ../sleepyhead-code/SleepyHeadQT.pro DEFINES+=BrokenGL
$ make
Post Reply Post Reply
#24
my current qmake line, to cut down on the flood of warnings:

qmake DEFINES+=BrokenGL QMAKE_CXXFLAGS_WARN_ON=-Wall\ -Wno-unused-parameter\ -Wno-unused-but-set-variable\ -Wno-unused-variable\ -Wno-narrowing -o Makefile SleepyHeadQT.pro

not that it matters... just makes the compile look a bit nicer Wink
Post Reply Post Reply
#25
OK, trying to build sleepyhead on Mac, getting webkitwidgets error. qt 5.10 installed via home-brew. Do I need to get 5.5?
Post Reply Post Reply



Donate to Apnea Board  
#26
Certainly 5.5 will include WebKit, I'm not sure if 5.6 includes WebKit by default. I'm not sure what's what on the Mac side.
Post Reply Post Reply
#27
I developed on Unix bad in the early to mid 80s, and from then on have been developing windows software. Got a Mac book pro to play around with, but the installation of things it a bit different than it was 35+ years ago... I tried to re-install qt with --with-qtwebkit. Let me search around to see if qt later than 5.5 supports it, and if so, how to get it installed.
Post Reply Post Reply
#28
OK, uninstalled qt10.1 or whatever, and installed qt 5.5 with:

brew install qt@5.5

Then had to edit bash config to point to new location:

echo 'export PATH="$(brew --prefix qt@5.5)/bin:$PATH"' >> ~/.bashrc

Now getting an error about undeclared fabs function, going to hunt down where that may have moved...
Post Reply Post Reply
#29
Simple #include "math.h", now to see if the other / base includes are nethack like in their complexity. 

And, sadly, at one time I understood netback source code and help add a holy handgrendade (bad idea to carry it around) and extra attacks for cat (two claw attacks).
Post Reply Post Reply



Donate to Apnea Board  
#30
There is a prebuilt mac release of Sleepy head no need to build from source ?
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Latest ChromeOS to Support Linux Apps Crimson Nape 0 180 06-19-2018, 10:24 AM
Last Post: Crimson Nape
  Oximetry - Do any of the pulse oximeters work with linux? happydreams 51 10,697 06-02-2018, 10:21 AM
Last Post: GordK
Idea SleepyHead and Linux MartinT 11 1,043 12-30-2016, 11:35 AM
Last Post: Crimson Nape
  did Linux corrupt my SD card? AirPlease 6 1,234 09-23-2016, 02:06 AM
Last Post: zagam
  SleepyHead and Linux Mint 17.3 (Ubuntu 14.04) necochino 4 950 08-21-2016, 07:16 PM
Last Post: pholynyk
  Building SleepyHead on Linux archangle 38 10,182 04-09-2016, 12:40 PM
Last Post: happydreams
  Add Linux download to the Sleep Files site hfinger 11 1,879 01-13-2016, 05:48 PM
Last Post: DariaVader

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.