Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

SleepyHead upgrade problem - "Loading Journal data..."
#1
I am trying to upgrade SleepyHead from version 0.9.3-beta-win32 to the latest version, SH 1.0.0-beta2 and I'm having a problem loading my 0.9.3 profile into the new version.  

After a bit of time doing the import of 3 years worth of daily data SH shows a pop up box that says "Import Success - Imported 1441 CPAP session(s) from...".  But then a different box pops up with a progress bar that says "Loading Journal data..." and when it gets to 37% SH crashes.  A new box pops up that says SleepyHead-BrokenGL.exe has stopped working.  (It also stops at the same point if I use SH OpenGL, but OpenGL won't run properly on my system.)

I can successfully import the data from the SH 0.9.3 "Backup" sub-directory, but when I do this I lose all the notes and machine settings.  I've taken a lot of daily notes that I would really like to keep.  It also does not import the machine settings correctly and says the pressures were set to min 5.0 and max 9.0 every day.  In SH 0.9.3 I have 20 or so "Changes to Prescription Settings" but after the import to SH 1.0.0-beta2 I only have 1 prescription setting.

In another thread someone suggested to "Rebuild" the database in the older version of SH and then trying the upgrade again.  I don't see a "Rebuild" option for the main database in SH 0.9.3, is there one and I'm missing it?

I also tried upgrading to SH 0.9.8 because I see that does have a "Rebuild" option.  Unfortunately, it behaves the same as SH 1.0.0-beta2 and crashes while "Loading Journal data...".

Any ideas on what I could try to upgrade SH and have it automatically load my 3 years worth of daily data?


COMPUTER:  HP Pavilion dm4-1201us laptop running Windows 7 Ultimate 64 bit ver 6.1 service pack 1, with Intel graphics card.  APAP:  ResMed S9 Autoset.

(I tried to post screen shots showing the problem but the forum won't let me until I have 4 posts.)
Post Reply Post Reply
#2
there is one thing you can try:

- first backup your profil folder.

- than go into it and open "Profile.xml" in an editor (notepad, notepad++ .... will do fine - simply hitting enter does NOT)
search for <CombineCloserSessions type="int">240</CombineCloserSessions> (type might also be "double" - the value may vary)
change the value - here 240 to 0 (zero).
save it.

try loading that profile.

if this does not help:
in your profile folder there should be a "journal_xxx" folder (where xxx are some random numbers and letters)
inside that folder should be a "Summaries.xml.gz" or "Summaries.xml" - delete that one

try opening that profile now.

If it helps or not at all please respond back.
Post Reply Post Reply
#3
TBMx, thank you very much for giving me some ideas to try!

For your 1st suggestion, I had in my SH 0.9.3 Profile.xml:

 "<CombineCloserSessions type="double">240</CombineCloserSessions>" 

and I changed it to:

 "<CombineCloserSessions type="double">0</CombineCloserSessions>"

Then I didn't know if you wanted me to immediately try to upgrade or first run SH 0.9.3 on that profile, exit SH 0.9.3 and then upgrade to SH 1.0.0, so I immediately tried to upgrade after making the change to Profile.xml.

SH 1.0.0 popped up a box quickly about Journal entries that went away before I could read it, then let me load the old profile.  It spent about 10 minutes "Rebuilding from ResMed Backup", got to 100% and finished successfully with 1441 records imported.  Then, oddly, it did not pop up the next "Loading Journal Data..." box where it had always crashed in the past, it just worked!  

Thank you very much TBMx, all my old notes are now back!  

The only thing that seems to be missing now is my "Changes to Prescription Settings" from some reason it brought them all in under 2 entries rather than the 20+ I have in SH 0.9.3.  It's not a big deal but if you have any ideas on how to restore that I'm up for it.
Post Reply Post Reply


#4
I'm glad it worked.

Please keep in mind that working with different versions of SleepyHead on the very same data-folders is a really bad idea! - they do store some things differently so you might end up destroying your data. (If you need to than please make a copy!)

regarding the "change in prescription":
could you please post a screenshot of that in the old and the new version?
Are you absolutely sure that you really changed your pressure-settings over 20 times? And have you looked if all your data is really there? (maybe SH imported just the last year or so?)


regarding notes in SH 1.0.0:
there is one nasty bug: if you create a note to a "last day" it can happen that in the overview your pressure graph looks scary. If it happens you will see that day no longer seem to have data and / or it gets a negative, really large value. (to some degree the "combine close sessions" setting to off counters that)
- "last day" meaning not only the very last day but every day, where the next day has no data.
- note meaning a note, the zombie-meter and the weight (or simply everything in the note-tab)

[i]If (only if) this happens to you (it might - it does not need to):[/i]
identify these days in the overview (pressure graph) - go in the daily view to these days - than from the menu: data --> advanced --> purge current selected day.

than double check that in the preferences, you set the "combine close sessions" to off (first tab there - first slilder)

exit sleepyHead once and open it again ... from the menu: "data" --> "rebuild CPAP-Data" --> your machine
everything should be "fine" now

to avoid that very situation (once again: combine-close-sessions to off helps only to some degree!)
do not add posts to the "last day" - only use the days before that.
never, ever assign a note to days sleepyhead has no data!
Post Reply Post Reply
#5
TBMx, I do realize that using different versions of SH on the same data file would be bad and I have not done that.  While I try to figure out this upgrade I have at least 6 copies (at 4 gb each) of the databases, 1 for each of the 3 different versions of SH I've been testing plus backups.  The only time I have a version of SH work on a database that isn't it's own is when I'm having it try to upgrade that database (and then it's a copy of the older database).

After you gave me the tip about "<CombineCloserSessions type="double">0</CombineCloserSessions>" and it worked during the upgrade, I decided to try it on a copy of the database that had already been upgraded by SH 1.0.0 but was always crashing SH each time it loaded.  When I made that change to it's Profile.xml SH 1.0.0 loaded that database just fine.

I will post screenshots of the "change in prescription" but I need to do 2 more posts before apneaboard will let me.  The changes were all done during 2014 when I was trying to figure out what was best for me, so they aren't that important anymore.  But yes the data really is there from 2014, I can look at each of those days and see the "flow rate" and everything for the day, it's just that the machine settings for those days are not reported correctly.

Regarding notes, I've either been really lucky, or is SH 1.0.0 different in this regard than SH 0.9.3?  I almost always post a note on the days that I don't use my CPAP to let me know why I didn't use it.  I must have more than 50 days that have no data and only a note.  And I'm not sure I understand correctly what "last day" is but I usually make a note on the day I import data to SH, which I assume is the "last day".  So far I haven't noticed anything unusual in the Overview pressure graph.
Post Reply Post Reply
#6
keep on posting^^ .. you're nearly there.

the notes are (or seem to be) different in 1.0.0.
If you notice the "odd" behavior you know now what to do - it's not like "you always run into trouble" - but you might.^^
Post Reply Post Reply


#7
Another question regarding database size and file count.  (And so I can get my post count up, to post screenshots.)

My SH version 0.9.3 "Profiles" subdirectory (the database) has about 15,100 files in it.  When I had SH 1.0.0 upgrade from version 0.9.3 the resulting 1.0.0 database also has about 15,000 files in it.  However when I "imported" the 0.9.3 database into 1.0.0 (instead of upgrading) the resulting 1.0.0 database only has about 8,100 files in it (and no notes).  Do the notes make up the additional 7,000 files or are there 1,000's of files that I could safely remove from the database?
Post Reply Post Reply
#8
the notes can easily do that ... you can always look insinde the folder for the notes (datafolder\Journal_xxx\ <-- all the files here are basically your notes)
Post Reply Post Reply
#9
Ok, lets see if I can figure out how to link to screen shots.

This is SH v 0.9.3 "Changes to Prescription Settings"
[Image: Y5Q4mkUl.jpg]

This is SH v 1.0.0 "Changes to Prescription Settings"
[Image: HD9Py41l.jpg]

And here is SH v 0.9.3 on 5-19-2014 showing the correct machine settings:
[Image: 78U029El.jpg]


And SH v 1.0.0 on 5-19-2014 showing the wrong machine settings:
[Image: uIz7ihyl.jpg]
Post Reply Post Reply


#10
that's odd ... try rebuilding CPAP-Data (again) and see if that helps.

if not: well ... maybe just stick with the working version and not upgrade?
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Trying to get Sleepyhead to read data from my Aircurve 10 Vauto alps 6 109 12-09-2017, 06:04 PM
Last Post: alps
  Missing Sleepyhead old data yankees123 6 179 12-09-2017, 04:20 PM
Last Post: AlanE
  SleepyHead..removing pulse ox data Allessio77 5 101 12-09-2017, 10:47 AM
Last Post: Sheepish
Arrow [Admin Note] SleepyHead Dreamstation AutoSV Patch [DATA NEEDED see post #2] Greggory 31 1,511 12-08-2017, 06:26 PM
Last Post: Sleeprider
  sleepyhead crashes when updating data jgoole 12 1,495 12-03-2017, 10:41 PM
Last Post: bighopper
  Can I send SleepyHead-readable data as an email attachment? VisitorX 4 190 11-22-2017, 05:39 PM
Last Post: archangle
  Detailed Data not downloading on Sleepyhead KatyDid 10 433 11-21-2017, 10:47 PM
Last Post: justwonderapnea

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.