Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Sleepyhead crashes downloading SD card
#1
I have installed the latest Sleepyhead version on a Windows 10 64-bit PC.   It installs normally and opens normally.

However as soon as I import from my SD card, Sleepyhead crashes.

The Debug screen simply shows:

PRS1Loader:Big GrinetectPath = "E://P-Series
Found "PRS1 datacard at "E:/""

No further debug details appear as the program crashes.

I know that there can be issues with SD card readers in Win 10.  I tried using an external USB card reader, but the same problem occurred.

The card itself is a standard Respironics one, and downloads normally to Sleepyhead on an old Win 7 PC.  However it will not work on the new Win 10 one.

Running as Administrator makes no difference.

I have tried re-installing but the same problem occurs.

Can anyone help please?
Post Reply Post Reply
#2
Try copying your SD card to a dedicated directory on your PC. Then point the Import path of SleepyHead to it and see what happens.
______________________
Useful Links -or- When All Else Fails:
Posting SleepyHead Charts in 5 Easy Steps
Robysue's Beginner's Guide to Sleepyhead
Apnea Helpful Tips
Post Reply Post Reply
#3
Many thanks

I uninstalled Sleepyhead completely and re-installed it, then pointed it to the directory stored locally on the PC (copied from the SD card).

Exactly the same problem.  Sleepyhead crashes as soon as it starts to download the data locally.

That presumably means that the SD Card Reader is not to blame.   I also do not think the data itself is faulty, because it downloads perfectly to Sleepyhead on a Win 7 PC.

The PC is a new Dell, running Windows 10 Version 10.0.14393 Build 14393

The data was stored on the OneDrive directory.

I am not sure what to do now - all very odd.
Post Reply Post Reply


#4
Let's check one more thing, to rule out a graphics driver problem. Try using the SleepyHead-BrokenGL.exe in lieu of the normal SleepyHead.exe. It's located in the same directory as SleepyHead.exe.
______________________
Useful Links -or- When All Else Fails:
Posting SleepyHead Charts in 5 Easy Steps
Robysue's Beginner's Guide to Sleepyhead
Apnea Helpful Tips
Post Reply Post Reply
#5
Thank you.

The Broken GL version has exactly the same problem, again reading the data stored locally.

I tried a complete re-install, and adding a second new profile, but to no avail.

All very odd - I used Sleeepyhead successfully for several years on the Win 7 PC, but it simply will not run on Windows 10
Post Reply Post Reply
#6
If Windows 10 was a fresh install chances are you may not have the latest version of Microsoft's Visual C++ Redistributable files.  I believe it's named MS VC++ Redist 2013. . .Found it! Here is the link:  https://support.microsoft.com/en-us/help...le-package
______________________
Useful Links -or- When All Else Fails:
Posting SleepyHead Charts in 5 Easy Steps
Robysue's Beginner's Guide to Sleepyhead
Apnea Helpful Tips
Post Reply Post Reply


#7
Thanks

Yes, it is a brand new Win 10 machine.  However, it is running Visual C++ Redistributable (x64) 12.0.30501.

According to the MS link you mentioned, it might need 12.0.40660.0 or later.

I'll try it tomorrow and let you know.

Many thanks for your help
Post Reply Post Reply
#8
I installed the Visual Studio upgrade 3170560 but it made no difference.  I then installed KB3174417, again to upgrade Visual Studio 2013.

Again it made no difference.  I did un-install and re-install Sleepyhead from scratch before testing.  However it still crashes as soon as the data is imported.

For reference, I am now running Visual C++ Redistributable (x64) 12.0.40660.0     The msvcr120.dll is also now version 12.0.40660

I checked the old Win7 PC.  That was running Visual C++ 2013 Redistributable (x86) 12.0.21005 and therefore msvcr120.dll with version 12.0.21005.1.  Sleepyhead ran with no problems there.

On the Win 10 PC, the latest x86 version is Visual C++2012 Redistributable (x86) 11.0.61030

I wonder if I need to put on an x86 version of Visual C++2013 Redistributable.

Sorry this is so technical.   Any thoughts please?

Many thanks
Post Reply Post Reply
#9
I think you do need to install the x86 version as well. Have you tried setting the Compatibility Mode?
______________________
Useful Links -or- When All Else Fails:
Posting SleepyHead Charts in 5 Easy Steps
Robysue's Beginner's Guide to Sleepyhead
Apnea Helpful Tips
Post Reply Post Reply


#10
Thanks

I put the x86 version on - it still made no difference.   Import now fails at 43%.  Compatibility with Win 8, Win 7 and Win XP SP3 makes no difference.

I was running v0.9.5 on the Win 7 PC.  Is there any way I can get hold of a copy of the same version to try on the Win 10 PC ?

I know the datacard is ok because I have used it on the old Win 7 PC to import into Encore Viewer Pro and it imports perfectly there.   It also imports ok into Sleepyhead v0.9.5 on the Win 7 PC.

I would like to try installing that version on to the Win 10 PC if poss, unless you have any other suggestions.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  sleepyhead SD card download kooly 6 218 10-09-2017, 08:18 PM
Last Post: AlanE
Angry EncoreBasic SD card problem [non-PR card?] medinamike 5 134 10-08-2017, 12:04 AM
Last Post: SuperSleeper
  SleepyHead and non-readable card. SleepDane 6 257 08-26-2017, 06:03 AM
Last Post: archangle
  Help downloading Data for Sleepyhead rpenguin 7 325 07-25-2017, 07:22 AM
Last Post: rpenguin
Question SleepyHead bug or SD card problems? Joselito Cabral 8 469 07-08-2017, 09:05 PM
Last Post: Joselito Cabral
  Sleepyhead doesn't pickup card data Surfbear 21 1,225 06-15-2017, 08:04 AM
Last Post: Surfbear
  Downloading SleepyHead harmon k 2 411 05-13-2017, 03:13 PM
Last Post: harmon k

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.