Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Sleepyhead not importing/reporting data correctly?
#21
RE: Sleepyhead not importing/reporting data correctly?
(08-26-2018, 08:15 AM)allanri Wrote: So it happened again; SleepyHead is reporting ZERO events from last night.


(There's also an unexplained gap in the middle of the night, but that's another problem ...)

It is reporting 3 events from a short nap I took earlier in the day, but it's not catching anything from last night. The machine reported an AHI of 6.something, and if I load the data in ResScan (which I don't do regularly, because it's a pain to run it on my Mac), the data is all there. 

I usually use FlashPap to pull the data off my FlashAir card, and it works perfectly.  To make sure, I inserted the SD card into my computer directly; I still get the same results.

I've tried using the "Report a Bug" feature of Sleepyhead, but it takes me to a 404 error web page.   I've posted a comment in the Sleepyhead space on Discord ... not sure what else to do?

[Edit]
I ran SleepyHead under Windows, and it does show the data ... except ... the details about my nap from earlier in the day do not appear.  Curiouser and curiouser ...
I suspect your oximeter import is messing up your time, etc.  Note: 13:19am to 8:03am does not equal 8:58 hours.  You might try deleting that data and just installing your PAP data to see if all events appear.  Just a hunch...
Post Reply Post Reply



Donate to Apnea Board  
#22
RE: Sleepyhead not importing/reporting data correctly?
(08-29-2018, 05:39 PM)trance Wrote:
(08-26-2018, 08:15 AM)allanri Wrote: So it happened again; SleepyHead is reporting ZERO events from last night.


(There's also an unexplained gap in the middle of the night, but that's another problem ...)

It is reporting 3 events from a short nap I took earlier in the day, but it's not catching anything from last night. The machine reported an AHI of 6.something, and if I load the data in ResScan (which I don't do regularly, because it's a pain to run it on my Mac), the data is all there. 

I usually use FlashPap to pull the data off my FlashAir card, and it works perfectly.  To make sure, I inserted the SD card into my computer directly; I still get the same results.

I've tried using the "Report a Bug" feature of Sleepyhead, but it takes me to a 404 error web page.   I've posted a comment in the Sleepyhead space on Discord ... not sure what else to do?

[Edit]
I ran SleepyHead under Windows, and it does show the data ... except ... the details about my nap from earlier in the day do not appear.  Curiouser and curiouser ...
I suspect your oximeter import is messing up your time, etc.  Note: 13:19am to 8:03am does not equal 8:58 hours.  You might try deleting that data and just installing your PAP data to see if all events appear.  Just a hunch...
I just read through this thread again and would like to say please ignore my previous response. Good night all.
Post Reply Post Reply
#23
RE: Sleepyhead not importing/reporting data correctly?
(08-28-2018, 09:32 AM)allanri Wrote: Tried that.  Didn't work.  I think it's some kind of a data corruption issue related to using your CPAP device at two different times during the day, and switching therapy modes.  Though because I can't remember exactly what I did, or the order in which I did it, I can't write a test case that would exercise the appropriate code paths.

But then again, maybe it's not a data corruption issue?  Because I am not able to replicate the same issues on Windows; when I import the same data into Windows, it works.  I do everything else on my Mac, so I'd rather find a way to get it working on OSX.

(08-29-2018, 01:35 PM)allanri Wrote: That might be it. I think I did download the nap info 1st, and then the next day, downloaded the overnight data.

I had a similar issue with SleepyHead last night.  I have also been having a short day nap and usually I do upload the data to SleepyHead after a nap but had no issues with the data.  Yesterday I had a 40 min sleep in the afternoon but I did not upload the data after this, and then slept until about 10am today (2 hours or more worth of insomnia in that) and the data did not match what was showing on my Dreamstation.  Sleepyhead was saying I had the machine on for less than 2 hours, but data in the daily section clearly shows I slept for 7 hours and 30 min.  I have no idea what is going on either as I have had no issues with SleepyHead up until now.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  importing oximetry in Oscar problems. car54 7 155 06-19-2019, 11:44 AM
Last Post: pholynyk
  Importing current vs history PhoebeAnn 0 50 06-18-2019, 08:10 AM
Last Post: PhoebeAnn
  OSCAR [unable to import data after original migration of SH data] OpalRose 23 723 06-02-2019, 02:17 PM
Last Post: OpalRose
  OSCAR -- Unknown Reporting Error In Overview RWS0022 10 230 06-02-2019, 01:07 PM
Last Post: Apnea Infant
  SleepyHead Data to Oscar HoseHead58 8 334 06-01-2019, 03:29 PM
Last Post: HoseHead58
  Importing Oximetry Data in Sleepyhead aehjr 28 11,597 05-08-2019, 09:14 PM
Last Post: dlbzone
  Getting Sleepyhead data to Excel PhoebeAnn 6 189 04-22-2019, 03:44 PM
Last Post: PhoebeAnn


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.