Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Tips for SpO2 Assistant 3.0.0 in Windows
#1
Just wanted to share my recent experience with the SpO2 Assistant 3.0.0 software that came with my CMS50IW Pulse Oximeter. At first it all seemed simple enough, but I quickly realized there were some quirky things going on with file permissions in Windows. This is because Windows requires elevated privileges to write to any location under your Program Files folders. Most programs understand this and store your user data off somewhere under My Documents, but I guess these guys decided to cut corners or simply ignore safe computing practices.

I connect to my CMS via USB cable, so in the SpO2 Assistant's connections screen, I just disable all the Bluetooth options and then I mark the "View device stored data only" box. In the next screen, when I chose the segment(s) I wanted and clicked "Receive", I monitored my data directory located at "C:\Program Files (x86)\SpO2 Assistant V3.0.0\Data" and noticed that I couldn't see the new files there. However, if I chose to open files from within the SpO2 Assistant program, those files did indeed show up. Since the whole idea is to point SleepyHead to those files for consumption, this was not good enough.

I searched high and low and couldn't find a way to pick a new default data directory for the SpO2 Assistant to save its files. So I managed a little workaround using symbolic links. Here are the steps:

1) Create a new directory called "Data" somewhere where you have appropriate file permissions, like anywhere in or under your Documents folder (e.g. "C:\Users\YOUR_USERNAME\Documents\SpO2\Data")

2) Backup any of your existing SpO2 files from "C:\Program Files (x86)\SpO2 Assistant V3.0.0\Data" (or wherever) into your new Data folder.

3) Delete the "Data" folder located at "C:\Program Files (x86)\SpO2 Assistant V3.0.0\" along with any files inside, since you already backed them up.

4) Open an Administrative Command Prompt, like this for Win 8 or 10 or like this for Win 7.

5) Referencing the mklink command, type the following:
Code:
mklink /J "C:\Program Files (x86)\SpO2 Assistant V3.0.0\Data" "C:\Users\YOUR_USERNAME\Documents\SpO2\Data"
being sure to substitute the paths with the appropriate path for your user. The basic syntax is
Code:
mklink /J NEW_LINK_LOCATION ACTUAL_EXISTING_LOCATION

Now if you followed everything correctly, you should see a new folder icon in your SpO2 Assistant V3.0.0 directory called "Data" which has a little arrow in the icon that makes it look like a shortcut. That's exactly what it is. Now we're tricking SpO2 Assistant into thinking it has a Data folder like it expects to see, but since the actual location is in your user's Documents folder, the program can actually write its files correctly without elevated privileges.

Alternatively, you could just run SpO2 Assistant as an Administrator every time you download files from your device, but this method is safer and more convenient in the long run.
Post Reply Post Reply



Donate to Apnea Board  
#2
shawn42,
Since Win 7 there has been an intermittent file ownership problem on certain programs and won't allow the user to access or modify the files. I have a script to modify the registry that will add a command to the options menu to allow you to take file ownership when these problems occur. It also comes with a removal script if you decide to remove it. Although I can't think of a reason that you would want to remove it.

Post or PM me if you're interested.
Post Reply Post Reply
#3
Firmware version?

I received my CMS50IW yesterday. Although shipped directly from the manufacturer Contec (ordered through Alibaba Express), it seems to be an older version because the software disc had the older version 2.7 of SpO2 Assistant.

My firmware version is 0.9 (from the System menu on the wrist device).

I'd be grateful if anyone else who has a CMS50IW would post what firmware version they have.
Post Reply Post Reply
#4
I have the CMS-50IW. Both its firmware and software are version 0.9 and the SpO2 Assistant is version 2.7. What versions were you expecting?
Post Reply Post Reply
#5
(10-07-2016, 10:07 PM)Crimson Nape Wrote: I have the CMS-50IW. Both its firmware and software are version 0.9 and the SpO2 Assistant is version 2.7. What versions were you expecting?

The OP said his shipped with SpO2 Assistant version 3.0. I was especially interested to know whether the units shipped with the newer software also have newer firmware.
Post Reply Post Reply



Donate to Apnea Board  
#6
Thanks!  The code suggestion worked perfectly.  My issue in brief, now solved with this redirected code.  Just bought the CMS50F, ver. 3.6A, and was able to upload and review the first data set.  The next and subsequent day's uploading took place but no data on the chart, so I thought it was a recording/storage error or upload error.  I can see the file in the SPO2 Assistant software when clicking "review" to load the data, but the chart was blank after loading.  I couldn't copy the file to put it somewhere else using right click as it said it didn't exist.  Going into the Data file showed no files but for the "this-dir-intentionally-left-blank" file.  I could not unhide the files.  Now, with this code, that the data is written in a folder under my Documents, I can see and load the data.  Thanks for sharing this solution, Shawn42!  Brilliant.
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Cannot Connect Contec CMS50FW to Windows 10 gumleafau 18 389 07-02-2018, 12:10 AM
Last Post: gumleafau
  how to edit SPO2 files? JohnJ789 7 373 06-21-2018, 02:50 PM
Last Post: ShaunBlake
Idea CMS50D+ Add date and time to SPO2 file adrinef 21 3,291 06-20-2018, 12:18 AM
Last Post: Sheepish
  ResScan 5.5 cannot run in Windows 10 ant08 7 1,898 06-05-2018, 01:53 PM
Last Post: wkracke
Gross ResScan on Windows under VMWare on a Mac - whither the SD Card Reader? allanri 8 344 05-19-2018, 01:48 PM
Last Post: jaswilliams
  Help understanding SpO2 settings in sleepyhead MyronH 2 235 05-16-2018, 09:28 AM
Last Post: pholynyk
  ENCOREPRO2 AND UPDATING WINDOWS 10 Walla Walla 1 256 05-07-2018, 12:13 PM
Last Post: SarcasticDave94

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.