Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Transcend SQL server Compact error
#1
I have just obtained a Transcend miniCPAP through a mail order supplier. The package included the software.

It installed OK. But after the initial screens, it gave the following error:

Unable to load the native components of SQL Server Compact corresponding to the ADD.NET provider of version 8080. Install the correct version of SQL server component. Refer to KB article 974247 for more details

I tried this on two different computers - one with Windows 10, the other with Windows XP, and got the same result.

On reading the above article (on Microsoft's Knowledge Base) I recognised I was out of my depth. I am reluctant to try installing new system software on computers which are pretty standard - and, in the XP case, in no longer supported by Microsoft. I have installed and used many PC programs over the years, and never found anything as strange as this when using normal PC operating systems - a criticism of the Somnetics developers.

Any ideas how to resolve? The people who sold me the machine are not returning calls or responding to emails.
Post Reply Post Reply
#2
from Google:

I had a similar problem. I was opening a compact framework sql database and it gave me the following error:

Unable to load the native components of SQL Server Compact corresponding to the ADO.NET provider of version 8080. Install the correct version of SQL Server Compact. Refer to KB article 974247 for more details.
When looking up the article, it led me to the following Link. The following quote explains what went wrong:

Compact based applications generally program against the Compact ADO.NET provider (System.Data.SqlServerCe.dll). This provider in-turn communicates with the native Compact components. In order to avoid various inconsistencies, a Compact ADO.NET provider of a certain version can talk only to the Compact native components of the same version.
In the end I solved it by downloading and installing the service pack in the following link. http://www.microsoft.com/en-us/download/...px?id=5783

Post Reply Post Reply
#3
Thanks, eplantz

I implemented your suggestion on my XP machine, and it worked. So I have managed to set my CPAP.

The service pack is described as supporting up to Windows 7. Do you know if there is something different for Windows 10, or should I attempt the same fix? I would expect my new CPAP to last longer than my old XP computer.
Post Reply Post Reply




Possibly Related Threads...
Thread Author Replies Views Last Post
  Sleepyhead update question - Error showing trying to go from v0.9.8-1 to current NovaSleep 4 152 12-28-2017, 03:17 PM
Last Post: Crimson Nape
  Error terjello 5 309 12-02-2017, 09:49 PM
Last Post: terjello
  Encore Pro 2.20.6.0 error reading SD card StuGoldberg 6 301 11-29-2017, 04:11 PM
Last Post: StuGoldberg
  help please Philips BiPAP datacard error Kudell 6 278 11-25-2017, 02:06 PM
Last Post: Kudell
  Error dowloading data from Sd card for system one machine dangood_47 4 551 11-14-2017, 04:07 PM
Last Post: Sleeprider
  ResScan load error Paul862 17 1,755 05-31-2017, 05:10 PM
Last Post: z counter
  Memory card error Apnea_GM 18 1,185 05-23-2017, 06:47 PM
Last Post: Surfbear

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.