Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account

New Posts   Today's Posts

USB Download from Contec Oximeter to Mac

I don't own a CPAP (yet), just a recording pulse oximeter (Contec CMS50D+).

I don't own a PC.  I have an iMac, running OSX 10.10.5 (Yosemite).  

I bought the pulse ox based on the fact that Sleepyhead software was supposed to be compatible with both my oximeter and my operating system.

This was the sequence of events:

I downloaded SiLabsUSBDriverDisk (v. 4) and installed it.
I downloaded Sleepyhead (no version; says created by Qt/QMake) and installed it.

After recording all night long (in record mode), I plugged my oximeter into my iMac using the cable provided, still in recording mode.

I opened Sleepyhead, clicked on Oximetry Wizard and clicked Start.

In the Oximeter Type pulldown menu, I selected CMS50D+.

Then I clicked "Import Directly from Recording on Device" and it said this:

     Scanning for compatible oximeters
     Connecting to  Oximeter
     You need to tell your oximeter to begin sending data to the computer.
     Please connect your oximeter, enter it's menu and select upload to commence data transfer...

There is nowhere in the menu of the oximeter to "select upload".  After a while, I got this error message:

     Could not get data transmission from oximeter.
     Please ensure you select 'upload' from the oximeter devices menu.

Based on something I read on the internet, I made Sleepyhead Read only access for myself and everyone else, and locked it.
After repeating the above process, there was no difference, same error message.

Then I turned off the recording mode and repeated all of the above.  No difference, Same error message.

Then I reset Sleepyhead to the orginal "unlocked" and Read/Write for me, Read Only for others.  No difference, same error message.

The menu on the oximeter is very simple.  There is no way that I could miss the setting "upload" on it.  There is no such setting.

Anybody have a solution to this?

Post Reply Post Reply

Donate to Apnea Board  
Hi JazG! - Welcome

The 50D+ is a unique animal in the oximeter family and requires you to pat your head and rub your tummy to get it to connect.  Several users of this device have reported difficulties in the past.  Here are a couple of links. I hope they may shed some light on your problem. I used the search term, "cms-50d+" and went down the list.



Good Luck!
Post Reply Post Reply
See if this thread might be helpful:
Please organize your SleeyHead screenshots like this.
I'm an epidemiologist, not a medical provider. 
Post Reply Post Reply

Possibly Related Threads...
Thread Author Replies Views Last Post
  SleepyHead data download not working UserNH 2 171 03-17-2018, 10:38 PM
Last Post: UserNH
  ResScan_5.9 Download ? SarajkoAustria 4 219 03-07-2018, 08:27 AM
Last Post: silversnore
  Download SD card from Resmed S10 and MAIL IT dsalles 7 332 02-20-2018, 09:15 PM
Last Post: edfreeman
  SleepyHead - imported oximeter messed up the graphs MyronH 2 228 02-18-2018, 09:10 AM
Last Post: Walla Walla
  Sleepyhead with Masimo Radical 7 Oximeter cbr1 2 365 02-13-2018, 01:32 PM
Last Post: bsmorgan
  Problems with SP02 Assistant v 3.0.4 not recognising Oximeter Contect CMS50E MaxHatman 4 425 01-01-2018, 05:43 AM
Last Post: MaxHatman
  sleepyhead SD card download kooly 6 461 10-09-2017, 08:18 PM
Last Post: AlanE

Forum Jump:

New Posts   Today's Posts

About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.