Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

USB to UART Bridge problem
#1
I am in the process of moving to a new computer, old PC Windows 7, new PC Windows 8.1.
Sleepyhead works fine but SPO2 Review V1.5 can not import recorded data from oximeter CMS50D+. I installed the Silicon Labs CP210x USB to UART Bridge driver, 64 bit version.
When I run the SPO2 Review I get a message "Device Connected, waiting for data" but no data is downloaded. Any suggestions?
Reply
#2
Hi ragnar33,
WELCOME! to the forum.!
Hang in there, someone will be along to help you with your computer problems.
Much success to you with your CPAP therapy.
trish6hundred
Reply
#3
(06-17-2015, 06:43 PM)trish6hundred Wrote: Hi ragnar33,
WELCOME! to the forum.!
Hang in there, someone will be along to help you with your computer problems.
Much success to you with your CPAP therapy.

Thank you trish6hundred, you are a real vet, I only started in March 2010.
Reply


#4
(06-17-2015, 04:28 PM)ragnar33 Wrote: I am in the process of moving to a new computer, old PC Windows 7, new PC Windows 8.1.
Sleepyhead works fine but SPO2 Review V1.5 can not import recorded data from oximeter CMS50D+. I installed the Silicon Labs CP210x USB to UART Bridge driver, 64 bit version.
When I run the SPO2 Review I get a message "Device Connected, waiting for data" but no data is downloaded. Any suggestions?

Now the download worked, I amnot aware of any changes I made Smile

Reply
#5
(06-17-2015, 07:51 PM)ragnar33 Wrote:
(06-17-2015, 06:43 PM)trish6hundred Wrote: Hi ragnar33,
WELCOME! to the forum.!
Hang in there, someone will be along to help you with your computer problems.
Much success to you with your CPAP therapy.

Thank you trish6hundred, you are a real vet, I only started in March 2010.

You might have joined March 2010 but two things;
1. Your Join Date is listed as June 2015.
2. This is only your third post.
Statistics prove that people who have more birthdays live longer.
Reply
#6
Maybe xPAP user since 2010? Given trish6hundred has in other comments: "I started CPAP in 2008."

Just a guess...


Using FlashAir W-03 SD card in machine. Access through wifi with FlashPAP or Sleep Master utilities.

I wanted to learn Binary so I enrolled in Binary 101. I seemed to have missed the first four courses. Big Grinnie

Reply


#7
My CMS50D+ requires a special cable ... took me a few tries to find the right one. Any chance you swapped to the correct cable?

-- oh wait - you said it connected but didn't find data... I've had that happen on Win7. I believe it is the v1.5 software not being too robust -- or the fact the cable itself is doing something untoward to fool the USB port into thinking a non-standard device is in compliance.
Reply
#8
I see you are using SpO2 Review v1.5. While I'm not using a 50D+, my software does support that model and is named SpO2 Assistant v2.7. You might need to update your software to be compatible with the OS.
Statistics prove that people who have more birthdays live longer.
Reply
#9
Also - the SpO Review software is an odd one -- takes forever to download data and sometimes multiple tries connecting to the device. I chatted with the manufacturer and they agree the software could use some polishing - in other words: it's broken and we won't fix it. Also - the software version is tied to the firmware - so a device with FW v4.6 needs SW v1.5 Review and v1.5 Assistant is only for real time use. They don't recommend using newer software that didn't come with the device (likely they didn't check FW & SW for compatibility).
Reply


#10
(06-18-2015, 03:53 PM)ragnar33 Wrote: Now the download worked, I amnot aware of any changes I made Smile

Ragnar (Vikings fan?) did you just keep it plugged in for several hours or how long did it take to download? Mine works on the live view program but gets hanged up at the exact same spot your is.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Drop Down Box Problem nadprok 4 87 01-19-2017, 10:29 PM
Last Post: nadprok
  Problem with gas (farting) Cribbe 7 375 01-07-2017, 06:51 AM
Last Post: Cribbe
  Hissing Problem with Eson mask/tube connector Southerngent1 13 368 01-04-2017, 11:22 PM
Last Post: trish6hundred
  Totally Confused by Airsense 10 Data - Centrals - Problem machine... ? mymontreal 40 2,305 01-01-2017, 09:20 PM
Last Post: richb
  Insurance Compliance Problem fotomatt1 9 419 12-21-2016, 01:49 AM
Last Post: DeepBreathing
  [Equipment] Is moisture staying in hoses a problem? ac110 13 579 12-18-2016, 08:13 AM
Last Post: OpalRose
  Problem with Autosense 10 central apnea detection johnthesleeper 30 2,584 12-16-2016, 10:01 AM
Last Post: Marvinator

Forum Jump:




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.