Apnea Board Forum - CPAP | Sleep Apnea
Unable to init SSL Context - Printable Version

+- Apnea Board Forum - CPAP | Sleep Apnea (http://www.apneaboard.com/forums)
+-- Forum: Public Area (http://www.apneaboard.com/forums/Forum-Public-Area)
+--- Forum: Software Support Forum (http://www.apneaboard.com/forums/Forum-Software-Support-Forum)
+--- Thread: Unable to init SSL Context (/Thread-Unable-to-init-SSL-Context)



Unable to init SSL Context - SotonSleeper - 04-29-2017

I am using Sleepyhead v0.9.5 on 64-bit Win7 Pro.   It has worked smoothly, but a few months ago it started throwing the above error message when checking for updates.

I have tried running as Administrator but it makes no difference.

Can anyone assist please.


RE: Unable to init SSL Context - Crimson Nape - 04-29-2017

Welcome to the forum!
You version may not contain the proper code to connect to a secure website.   You are using a version that has been superseded a couple of times.  You can turn off the option to check for updates and that should alleviate your problem.   Or, you can download the latest version by clicking on this link for SleepyHead.


RE: Unable to init SSL Context - SotonSleeper - 04-29-2017

Many thanks Crimson Nape.

I would prefer to download the latest version if poss.  Will this retain all my historical data?


RE: Unable to init SSL Context - Crimson Nape - 04-29-2017

It should. I've only had experience moving up from 0.9.8 to the latest, version 1.0. The newer version has a slightly different format and will update your current data files the first time you run it after install.


RE: Unable to init SSL Context - SotonSleeper - 04-29-2017

OK Many thanks.

I'll try it.  Fingers crossed!