Apnea Board Forum - CPAP | Sleep Apnea
Oscar / Resmed S9 / Unlocked SD Card problem - Printable Version

+- Apnea Board Forum - CPAP | Sleep Apnea (http://www.apneaboard.com/forums)
+-- Forum: Public Area (http://www.apneaboard.com/forums/Forum-Public-Area)
+--- Forum: Software Support Forum (http://www.apneaboard.com/forums/Forum-Software-Support-Forum)
+--- Thread: Oscar / Resmed S9 / Unlocked SD Card problem (/Thread-Oscar-Resmed-S9-Unlocked-SD-Card-problem)

Pages: 1 2


Oscar / Resmed S9 / Unlocked SD Card problem - eugene.robitaille - 09-14-2019

Hello,
I just installed Oscar on my computer and put my SD Card inside my computer. 
I did not know that you had to "Lock" the SD Card before you put it in the computer when your CPAP machine is a "Resmed S9". 

After getting the report, when I tried putting back my SD card in my CPAP, my Resmed S9 CPAP machine does not want to use it without formatting the SD Card. Doing a few verification's, I found out that my computer as installed a file on the SD card that creates problems specifically for Resmed S9 marchines. 
Can someone please tell me how can I find/erase the file that is creating the problem, so I could put the SD Card back in my CPAP machine ? 
What can I do to solve this issue ? I do not want to format my SD Card because it has all my CPAP history. 

Thanks a lot.


RE: Oscar / Resmed S9 / Unlocked SD Card problem - Crimson Nape - 09-14-2019

Hi eugene.robitaille - Welcome

The S9 is the only CPAP that has a problem with Windows writing the System Volume Information to an attached device.  This was done by MS to improve the indexing speed of the device.  I have just come up with a newer version of a uility that allows you to turn off this feature as well as, other options.  It also allows you to turn them back on if you desire.  It is a batch file (.bat).

After turning this feature off, you can reinsert your SD card back in your PC and delete the SysVol file.  That should get you going without having to reformat the SD card.

I have attached it below.
[attachment=15466]

Good Luck!


RE: Oscar / Resmed S9 / Unlocked SD Card problem - DeepBreathing - 09-14-2019

Note that Windows 10 runs regular updates and it has been known for the registry edits (eg per Crimson Nape's utility) to be undone by the update. Back to square 1. I've got in the habit of running the utility every time I download the card - it's very quick and easy.

Note also that many card readers don't possess the sensor to detect whether or not the card is locked, so the registry edit is really the only way to definitely protect the card.


RE: Oscar / Resmed S9 / Unlocked SD Card problem - eugene.robitaille - 09-15-2019

Thanks a lot Crimson and DeepBreathing for all your suggestions and all your work on this site,
It's really appreciated. 

So, for my part, I ran the .bat file and chose " 1. Show All Directories and Files and Disable System Volume Writing " . I seems to be working at this point.  like

I am on Windows 10 Pro 64 bit, so I started the process using a regular "Windows Explorer" interface, but I cannot see the "SysVol" file that I need to erase on my computer  Windows Explorer.  I , activated the "Show hidden files" button of Windows Explorer, still did not see the file. Sad
I opened a "Command prompt" to try to see the file using DOS command (I am not to good at this Cool  but I tried....). Did not work... Oh-jeez
So lastly I used "AstroGrep" (A software that I think is better than Windows Explorer) to try to find the file to erase. Did not see it neither. 
Can you please tell me how I can see the file so I can erase it  Unsure Unsure

Thanks again for all your help, and sorry that I created my own problem. 
Kind regards. 

Eugene  Huh Huh


RE: Oscar / Resmed S9 / Unlocked SD Card problem - eugene.robitaille - 09-16-2019

Hello Everybody, 

Just to put the post up to date, I called Resmed to ask why their S9 machine creates this problem. 

They gave me an awkward reason. But they also told me that the S9 machine has 365 days of information on it's own, so if I format the SD card, I will still get back 365 days of data anyway (which is enough for most people) Okay . So I formatted my SD card like they told me to do...
And in order to close this post, I did a test (I ask for the Oscar report just after the formatting). 

RESULT: Resmed S9 machine does keep general statistics for 365 days, but I lost all my "DataLog" and daily information's. 
Huhsign (that not what I was told by Resmed)  Dont-know Dont-know  (So do not format the card if you want to keep daily information's) 

Thanks a lot for all your help, but from my side, I cannot do anything anymore because formatting is already done !!!!..... 

Special thanks for creating Oscar and for the replies on my questions. 
Thanks
Eugene


RE: Oscar / Resmed S9 / Unlocked SD Card problem - Sheepish - 09-16-2019

Salut Eugène,

Yes, as you found out and were poorly informed by the Resmed phone CSR, these machines retain basic information internally without the SD card, but detailed information is stored only on the SD card. That's why if you forget to insert your SD card (or reformat it), you'll only have basic data. The detailed data you can access in Oscar comes from the SD card.

Voilà, c'est comme ça. Oh-jeez


RE: Oscar / Resmed S9 / Unlocked SD Card problem - gm125 - 11-17-2019

This solution isn't working for me.

I opened a CMD shell as Administrator, and ran the bat file with option 1. It reported that  "System Volume Information Writing is Disabled"
I then flipped to write protect (not that this seems to do anything) and installed my SD Card.
I don't see anything called Sysvol, in explorer or in cmd shell.
Nonetheless, when I return the card to my S9, it complains of an invalid SD card, and wants to reformat.

Just for comparison, I install the freshly formatted SD card into a Mac, using the same SD-USB adapter. It reads fine, and on return to the S9 the card is accepted fine.

So this definitely appears to be the issue of Windows writing something, but as indexing removable devices is now turned off at the policy level, and verified at the registry, and I've run the bat file ... that approach doesn't seem to be solving it.

What other reasons might Windows write something to the write-protected SD Card?   Oh-jeez

And just for the record, I don't want to use the Mac for Oscar, as it is a work computer.

Cheers


RE: Oscar / Resmed S9 / Unlocked SD Card problem - Gideon - 11-17-2019

Windows writes index ino to the SD card if it is not write-protected. This is only an issue with the S9.
There is a .bat file to correct that that someone will come along with.


RE: Oscar / Resmed S9 / Unlocked SD Card problem - gm125 - 11-17-2019

Is that the same bat file as linked above in this thread ("SystemModUtil.zip"), and which I said I've already used? Smile If so, didn't solve the problem for me.

Cheers


RE: Oscar / Resmed S9 / Unlocked SD Card problem - Gideon - 11-17-2019

Yes it is.