Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

[CPAP] FlashAir III w/ PR System 1 A-Flex
#1
FlashAir III w/ PR System 1 A-Flex
I recently replaced the stock SD card with a 16GB FlashAir III card (fat32), initialized it with FlashAir tool then overwrote the CONFIG file with that below.  All works well for a few hours, can run the xpap unit, saves to the card fine, can upload data with FlashPap that places data in Sleepyhead.  Rather randomly, usually sometime during the first night or when I stop the cpap, it writes to the card then reports a corrupt sd card and sometimes immediately goes into reformatting the card which it never finishes.  I take the card out and put in Win 10 box and all looks and works fine if it didn't try to reformat it. If it did reformat it some files on the card get wiped out or replaced with garbage. I've write/read surface scanned the card with two utilities, one being free port scanner the other minitool partition wizard and tests fine. Interestingly the xpap info screen reports only 17% free when it's actually 99% free.  Does this xpap require the card to be repartitioned smaller than 4GB and formatted as fat16?  I don't know what else to try.  As much time as I've spend this week trying to get stable operation I could have walked this card across the house every day for a year in less time. Frustrating!

[WLANSD]

ID=Cpap
DHCP_Enabled=YES

[Vendor]

CIPATH=/DCIM/100__TSB/FA000001.JPG
APPMODE=5
APPNAME=Cpap
APPSSID=TenX
APPNETWORKKEY=<secret>
LOCK=1
DNSMODE=1
APPAUTOTIME=0
UPLOAD=1
STA_RETRY_CT=0
HTTPDMODE=0
VERSION=FA9CAW3AW3.00.01
CID=02544d535731364740d5ae7179011101
PRODUCT=FlashAir
VENDOR=TOSHIBA
MASTERCODE=<secret>
COMMAND=fat cp /SD_WLAN/BCONFIG 1:/BCONFIG
COMMAND=fat cp /DCIM/100__TSB/FA000001.JPG 1:/FA000001.JPG
Post Reply Post Reply



Donate to Apnea Board  
#2
RE: FlashAir III w/ PR System 1 A-Flex
have you tried reserving the IP address for your FlashAir? Not sure that it will address the re-formatting, but kept on and off routine from happening to me.
Post Reply Post Reply
#3
RE: FlashAir III w/ PR System 1 A-Flex
Hi markn62,
WELCOME! to the forum.!
Hang in there for more answers to your question and good luck to you with CPAP therapy.
trish6hundred
Post Reply Post Reply
#4
RE: FlashAir III w/ PR System 1 A-Flex
Was the original card FAT16? I searched for an SD card memory limit and format spec for your machine, found nothing.
Post Reply Post Reply



Donate to Apnea Board  
#5
RE: FlashAir III w/ PR System 1 A-Flex
I have the same card in my Dreamstation Auto and on WIN10. It should be formatted FAT32 & this is my CONFIG file

#Fri Jun 09 19:17:57 MDT 2017
DNSMODE=0
APPMODE=4
CID=02544d535731364740d52d6879010c01
NOISE_CANCEL=0
APPNETWORKKEY=*********
PRODUCT=FlashAir
APPNAME=flashair
APPSSID=Phil
LOCK=1
APPAUTOTIME=0
VENDOR=TOSHIBA
CIPATH=/DCIM/100__TSB/FA000001.JPG
VERSION=FA9CAW3AW3.00.01

I have it MODE=4 so I have to connect to it via WiFi Vs over the router. I am doing this as I will be traveling in OZ for 3 months.

Hope this helps.
Post Reply Post Reply
#6
RE: FlashAir III w/ PR System 1 A-Flex
That model CPAP may be just old enough not to recognize a SDHC card or is only limited to FAT16. I couldn't find any info to help with these two ideas.
Post Reply Post Reply
#7
RE: FlashAir III w/ PR System 1 A-Flex
I really appreciate everyone's suggestions. Since my first post my xpap has error'd on the card twice again.  Really annoying when it happens at night beeping till I wake up and pull the card out.  Attached is a pic of the error displayed.  These last two I didn't tell the xpap to reformat the card but instead took it to my Win 10 box.  Running chkdsk d: /F the first time marked bad a couple sectors & kept all files intact so I thought great maybe it will be ok now, nope.  The last time the test came back clean, no problems.  So I thought I better double-check that I have Explorer set to show hidden and system files but system was still hidden and revealed a "system volume information" folder once corrected. It is now deleted and the card put back in the xpap, see how this goes this time.  Still reporting 17% free.

The original SD card is a Lexar, 2GB, Fat32, w/Phillips label.  It also had an SVI folder because I would take it to my PC and manually transfer P-series data and it never reported an error despite it's presence.  So it doesn't make sense the SVI folder would cause the error on the FlashAir card.  If removal of the SVI folder doesn't eliminate the error I think I'll retry a single 2G primary partition as fat32, like the original card, and see what happens.  Last time I tried repartitioning with Mini Tool Partition Magic it wouldn't take.   Thanks again everyone.  I'll keep posting status, hopefully success.
Post Reply Post Reply



Donate to Apnea Board  
#8
RE: FlashAir III w/ PR System 1 A-Flex
When I used a Resmed S9, I had to be careful to set write protection on the SD card before I placed it in my computer as Windows does write indexing files to every drive it encounters. If I failed to do that, the machine would want to reformat the card every time. I don't think this is your issue if you didn't have to do that with the "normal" card, but just food for thought.
Post Reply Post Reply
#9
RE: FlashAir III w/ PR System 1 A-Flex
markn62,
Do you have a regular 16 or 32 Gb SD card you could try in your machine?  Also, The S9 was the problem child with the Windows Sys files.  I have a registry mod file to disable or enable this feature in Windows.  

Here is the link if you would like it:

System Volume Write Disable/Enable

- Red
Post Reply Post Reply
#10
RE: FlashAir III w/ PR System 1 A-Flex
Yes Crims the original card the xpap was supplied with. Just enabled an item in Local Policy Editor to stop the folder creation. Can't edit the config file with card lock on so helpful. 

Came home this evening to a beeping xpap. Pulled the FlashAir & partitioned 2G of Fat16.

See how it goes...
Post Reply Post Reply



Donate to Apnea Board  


Possibly Related Threads...
Thread Author Replies Views Last Post
  Help with Settings for Respironics System One (60 Series) RemStar BiPAP Auto wjblevins 9 174 04-16-2019, 10:26 AM
Last Post: wjblevins
  Finding optimum settings for Respironics System One (60 Series) RemStar BiPAP Auto vinitwins 17 356 04-14-2019, 07:59 AM
Last Post: vinitwins
  PR System One Tube Heating locked off. truwest 14 1,784 03-27-2019, 03:46 PM
Last Post: Clay L
  [CPAP] Remstar Plus with c-flex kclark399 1 152 03-04-2019, 08:54 PM
Last Post: Sleeprider
  Dreamstation PRO FLEX cam 9 296 02-23-2019, 12:38 PM
Last Post: Fats Drywaller
  Bleep Sleep System (No straps/headgear) rooy1960 21 1,544 02-20-2019, 01:50 PM
Last Post: jaswilliams
  Easiest way to connect to FlashAir SD card using a static IP in Windows shawn42 18 5,400 02-17-2019, 08:31 PM
Last Post: Tubaman


New Posts   Today's Posts






About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.