Hello Guest, Welcome to Apnea Board !
As a guest, you are limited to certain areas of the board and there are some features you can't use.
To post a message, you must create a free account using a valid email address.

or Create an Account


New Posts   Today's Posts

Remstar Auto M Series "Service Required"
#1
Machine worked great and turned off normally in the AM. Turned machine on at bedtime and it came up with "SERVICE  REQUIRED" and buttons flash and machine beeps. I removed smart card and unplugged machine for a long period of time and still get massage when plugged back in. Any help in resetting or repair would be helpful.
Post Reply Post Reply
#2
Service would be more, or equal to a new machine. Your machine was issued between 2005 and 2008, and by now has far exceeded its expected life. Your choices are to obtain a new machine through insurance and a DME, or to buy online. FWIW, online prices for a new Philips Respironics Dreamstation on Amazon is about $400. Use that as a benchmark against getting a prescription renewal ($??), possible sleep study ($3000+), and acquisition through a DME at nearly $1800.
Post Reply Post Reply
#3
Try unplugging it from the wall. Then unplugging the cord from the back. Wait at least a minute. Plug it back into the back of the machine then into the wall again. I doubt it will make a difference but it might.

It sounds as if your machine has some sort of fatal error. Is there no error message other than Service Required? Are the beeps evenly spaced or seem to be a repeating pattern?
PaulaO2
Apnea Board Moderator
www.ApneaBoard.com


Breathe deeply and count to zen.

INFORMATION ON APNEA BOARD FORUMS OR ON APNEABOARD.COM SHOULD NOT BE CONSIDERED AS MEDICAL ADVICE. ALWAYS SEEK THE ADVICE OF A PHYSICIAN BEFORE SEEKING TREATMENT FOR MEDICAL CONDITIONS, INCLUDING SLEEP APNEA. INFORMATION POSTED ON THE APNEA BOARD WEB SITE AND FORUMS ARE PERSONAL OPINION ONLY AND NOT NECESSARILY A STATEMENT OF FACT.




Post Reply Post Reply


#4
Hi msgill59,
WELCOME! to the forum.!
Usually when you get beeps and a service required message, a new machine is in order.
Good luck to you with your machine decision and also with your CPAP therapy, hang in there for more responses to your post.
trish6hundred
Post Reply Post Reply
#5
Thank you all for your replies. Very disappointed with my machine on why it worked so well for many years and over night DEAD! Of course my prescription is older than a year and I need a new one. I just hate the process on getting a new machine. 

Cheers
Post Reply Post Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  RemStar Pro 2 w/C-Flex - parts needed blackhawk2737303 8 150 Yesterday, 06:57 PM
Last Post: Sleeprider
  [Admin Note] A TON of New CPAP Service Manuals SuperSleeper 4 168 12-07-2017, 04:35 PM
Last Post: Sleep2Snore
  REMstar SE service manual Baretty 7 253 11-16-2017, 08:26 PM
Last Post: Gary1of2
Sad [CPAP] Res Med S9 help! Error: Settings reset to default values, please contact service pr dexter020281 18 13,673 11-04-2017, 08:00 PM
Last Post: ajack
Smile Help with REM star m series rogertaurau 2 181 11-03-2017, 04:06 PM
Last Post: trish6hundred
  Respironics RemStar 60 Auto heated tube available? jaw2004 3 190 10-25-2017, 09:30 PM
Last Post: jaw2004
  [CPAP] Guidance required, 10+ months and no progress! antstephenson 21 845 10-25-2017, 01:23 PM
Last Post: antstephenson

Forum Jump:

New Posts   Today's Posts




About Apnea Board

Apnea Board is an educational web site designed to empower Sleep Apnea patients.

For any more information, please use our contact form.